Andman

RC Race Buggy - steering gears broken(?)

Recommended Posts

While steering I can here sounds I don't like. Before I do anything I would like to ask if anyone has experienced the same issues and if it could be fixed. If yes, how? Thanks in advance.

Share this post


Link to post
Share on other sites
Just now, Zerobricks said:

What model are you referring to?

I think it's the RC Race Buggy from 2002.

8475-1.jpg?200112121200

Edited by Maaboo35

Share this post


Link to post
Share on other sites
1 minute ago, Maaboo35 said:

I think it's the RC Race Buggy from 2002.

Correct. Sorry, I should have been clear in my initial post.

Edited by Andman

Share this post


Link to post
Share on other sites
16 minutes ago, Andman said:

Correct. Sorry, I should have been clear in my initial post.

No worries, the title did give it away anyway. Though this set also uses the same setup, so a little more information would have been good for the sake of specifics.

8376-1.jpg?200310180234

Edited by Maaboo35

Share this post


Link to post
Share on other sites

Some additional notes. The return-to-center unit works perfectly fine. The friction of the mechanism is ok. Though I think about applying some silicon grease. Any recommendations are welcome.

Share this post


Link to post
Share on other sites

These are getting pretty old. Anything plastic can eventually wear out. Or i may have dirt inside. Is the steering unit able to be disassembled for a look-see?

Share this post


Link to post
Share on other sites
11 hours ago, amorti said:

These are getting pretty old. Anything plastic can eventually wear out. Or i may have dirt inside. Is the steering unit able to be disassembled for a look-see?

Yes it is and I will open it to try to fix it. Just was curious if someone had to deal with that and fixed it. If there is no one, I'll share my experience.

Share this post


Link to post
Share on other sites

I've opened both the main unit, and the steering unit up before, as I'm a nosy person inquisitive... and there's not a lot to them

You should be able to notice any dirt,or other damage to the parts inside when you open them up.

They might just need a good clean, and fresh application of silicon grease

 

Share this post


Link to post
Share on other sites

I have also clicking with the same unit when thetre is to much torque, maybe there is a torque sensitive protection

Share this post


Link to post
Share on other sites

I opened it. Everything looks ok. The gear don't even have visible wear. I'll clean it and apply new grease. Later I'll upload some pictures and tell more about my assumptions reagarding the click sounds.

Just a quick addition. My assumption were wrong. I just found out that one of the gears has a built-in clutch. For those who have seen them: It's the white one with the spring. For the others: Picture will follow later (today or tomorrow).

Share this post


Link to post
Share on other sites
Just now, TechnicRCRacer said:

I thing I put the spring in incorrect.

Most likely. I'll open this unit again to put some Lub on it. I'll take some detail pictures. It was I bit tricky to get everything back in place, but it is doable. There is not much to break. 

Share this post


Link to post
Share on other sites
On 3/24/2020 at 3:43 PM, TechnicRCRacer said:

Please upload pictures, I opened mine and it won’t return to center anymore. I thing I put the spring in incorrect.

Sorry for the late response. Here are the pics. If they don't help, let me know.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.