Recommended Posts

55 minutes ago, Stephan said:

Are you able to send me your files? For some reason this parts keeps changing position which means that I mess up the files every single time for some reason...

Development Version 20210501 and

Development Version 20210828

Those were the 2 files I downloaded that had older versions of the 2x6 Tile.

It didn't change anything though. So I just moved them back into place after toggling physics test. (Turns out the parts missing from optimus prime weren't even related to them)

Share this post


Link to post
Share on other sites
2 hours ago, Takanuinuva said:

Not sure what happened to tile 2x6. But they all got flipped 180 in the update and cause a lot of clipping in my build of Lego Optimus. Not sure if it can be fixed as I tried reverting it to an older version of the part file.

 

I use 2x6's in mine and nothing has moved (since the last package that is)

Share this post


Link to post
Share on other sites

Good evening, gang.

I went ahead and installed the latest LDD update. Program keeps crashing after splash screen appears for a few seconds. Any suggestions?

Share this post


Link to post
Share on other sites
1 hour ago, Jason C. Hand said:

Good evening, gang.

I went ahead and installed the latest LDD update. Program keeps crashing after splash screen appears for a few seconds. Any suggestions?

If I had to guess. It's a part installed incorrectly.

Try loading just a project instead of letting the last 6 ones load?

Share this post


Link to post
Share on other sites
12 minutes ago, Takanuinuva said:

If I had to guess. It's a part installed incorrectly.

Try loading just a project instead of letting the last 6 ones load?

:thumbup: Will try.

Share this post


Link to post
Share on other sites
8 hours ago, anothergol said:

I use 2x6's in mine and nothing has moved (since the last package that is)

Good to hear, thanks :)

Share this post


Link to post
Share on other sites

Congratulations Stephan and thanks for your huge work.

Steering arm 4261's pegs do not connect to plate 4263's holes. Same issue with plates 2711, 4262, 4442 and 2719, as far as I know. That kind of connection is required in many Technic sets from the Eighties and the Nineties.

All other issues I noticed were solved.

Thank you again

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/17/2022 at 5:25 AM, Stephan said:

Added version 20220716: LINK.

This version includes 78 new parts, 135 updated parts, 253 new decorated parts, 3 new colors, a new version of the 2020NewPreColoredParts palette and a new version of the DecorationMapping!

Even though the parts are thoroughly checked, you might still encounter unforeseen problems during some builds. If that is the case, please let me know.

220716.png

For which parts are you most excited?

Enjoy :blush:

Only just had time to install the update, thanks for all the hard work! So far, everything seems to be working fine, but when I opened the latest 220716.lxf file, one of the Part 2654 got removed as a misplaced Brick.

Another issue is with Part 32828. As shown below, try attaching it through a 85861 plus a 3062 beneath, and even after being adjusted the very tip may still collide with the 85861. If the 32828 is only attached to a 85861, at the moment we can’t push the 32828 all the way upwards.

800x410.png

Also, if there is still time, could collisions be added to Part 35464 Slope 45 1x1 Double as this is the only newer Slope missing such data partially? For Part 25195, only the tube section requires collision data to be added while the Plate 1x6 at the base is fine, so this should be easy to do too. I’d happily expect to see these two Bricks modified for the next update if these can’t be done soon.

P.S., can the Decoration Mapping Image or Dimensions Data for Part 30259 Triangular Sign W. Snap be shared as I’m hoping to finally add some custom Triangular Warning Signs to my projects? Thanks in advance!

Edited by suenkachun

Share this post


Link to post
Share on other sites
Posted (edited)
14 hours ago, Takanuinuva said:

If I had to guess. It's a part installed incorrectly.

Try loading just a project instead of letting the last 6 ones load?

 

14 hours ago, Jason C. Hand said:

:thumbup: Will try.

Friend, I'm beginning to believe that several parts were not installed correctly, because every time I open and scroll down the Wheels/Tyre section or the Minifigure Heads section, LDD crashes and closes. I also uninstalled and re-installed LDD, making a backup of the Primitives folder. Silly thing still crashed and closed. Not sure what is going on at this point, please forgive if this post is redundant.  Think I fixed it now :)

Edited by Jason C. Hand

Share this post


Link to post
Share on other sites
On 7/17/2022 at 5:25 AM, Takanuinuva said:

2310.png

I don't recall this piece in any new sets. (New Elementary didn't cover it)

The geometry of https://www.bricklink.com/v2/catalog/catalogitem.page?P=73825&C=85#T=C&C=85 Also got messed up a bit and it's now sticking inwards a bit compared to other brackets.

The part still works it's just the visual piece is off center from it's hitbox

Tile 2x6 got moved around 2 studs in my build of Optimus. Making a bunch of parts get removed.

Just noticed one more issue: after the update, Part 11391 is still in an unknown category at the end of the Bricks menu, and now Part 9560 is in a second unknown category after the first. I’m guessing that 11391 should actually belong in one of the Minifigure categories while 9560 should belong in a Technic category? If not then perhaps the two Bricks can be placed into one unknown category instead of two separate ones, unless there is a good reason not to do so.

Part%2011351%20And%20Paart%209560.png

Share this post


Link to post
Share on other sites
28 minutes ago, suenkachun said:

Just noticed one more issue: after the update, Part 11391 is still in an unknown category at the end of the Bricks menu, and now Part 9560 is in a second unknown category after the first

The torso should not be in the category, which means you miss an assembly file.

The piston is a bit trickier: its partID got updated. Easiest thing to do is to delete the xml and g file of 9560.

Share this post


Link to post
Share on other sites
14 hours ago, Jason C. Hand said:

:thumbup: Will try.

Think I was able to fix the hang-ups from before. Thanks again.

Share this post


Link to post
Share on other sites
54 minutes ago, Stephan said:

The torso should not be in the category, which means you miss an assembly file.

The piston is a bit trickier: its partID got updated. Easiest thing to do is to delete the xml and g file of 9560.

Thanks for the info. Perhaps you could pinpoint the missing assembly file for the torso, as I’ve always copied and replaced all files in each release (except for the DecorationMapping.xml which I manually update) so everything should be installed properly.

1 hour ago, suenkachun said:

Only just had time to install the update, thanks for all the hard work! So far, everything seems to be working fine, but when I opened the latest 220716.lxf file, one of the Part 2654 got removed as a misplaced Brick.

Another issue is with Part 32828. As shown below, try attaching it through a 85861 plus a 3062 beneath, and even after being adjusted the very tip may still collide with the 85861. If the 32828 is only attached to a 85861, at the moment we can’t push the 32828 all the way upwards.

800x410.png

Also, if there is still time, could collisions be added to Part 35464 Slope 45 1x1 Double as this is the only newer Slope missing such data partially? For Part 25195, only the tube section requires collision data to be added while the Plate 1x6 at the base is fine, so this should be easy to do too. I’d happily expect to see these two Bricks modified for the next update if these can’t be done soon.

P.S., can the Decoration Mapping Image or Dimensions Data for Part 30259 Triangular Sign W. Snap be shared as I’m hoping to finally add some custom Triangular Warning Signs to my projects? Thanks in advance!

Please check these issues too.

Share this post


Link to post
Share on other sites

I have a couple of requests for parts to be modified and added. First, could the rest of these minidoll legs have the hip connector part added to them by means of assembly files, like the two parts on the right side of the image? (Apologies in advance if these have been distributed already and I just somehow missed them.)

Second, I notice that a few parts from the new Technic Ferrari Daytona set were added in the latest update, can we expect to see the rest soon? I'd like to have all of them available before I build it, going back and replacing parts inside these massive technic cars is very difficult. For reference, the remaining missing parts are 69761, 69762, 73389, 73398, 80274, 80278, and 80279.

 

Share this post


Link to post
Share on other sites
3 hours ago, suenkachun said:

Part 11391

You were there since the first updates. Newer versions don't have this part anymore. I believe it was double and faulty, but I am not sure anymore. Anyway: you can delete the files as well. Sorry for the inconvenience.

14 minutes ago, PicnicBasketSam said:

can we expect to see the rest soon?

As soon as I can find 3D models, we'll add them :) Same for the new Technic helicopter swash plate parts.

Share this post


Link to post
Share on other sites
Posted (edited)
40 minutes ago, Stephan said:

You were there since the first updates. Newer versions don't have this part anymore. I believe it was double and faulty, but I am not sure anymore. Anyway: you can delete the files as well. Sorry for the inconvenience. 

Thanks, I guess newer versions contain the three torsos but with arms included? If that is the case, I might delete the files of this Brick as well.

BTW, in case you want to check the latest 220716.lxf for the removed Part 2254, here is a copy saved on my end. Hopefully, you had time to look at the rest of the issues I mentioned as well (Part 32828, collisions for Part 35464 and Part 25195, Triangular Sign Decoration Mapping Image: I tried creating a custom Decoration using the current images but failed to do so, having a referencing image will be of great help). There was also the following info from an earlier post.

6 hours ago, marco9999 said:

Steering arm 4261's pegs do not connect to plate 4263's holes. Same issue with plates 2711, 4262, 4442 and 2719, as far as I know. That kind of connection is required in many Technic sets from the Eighties and the Nineties.

 

Edited by suenkachun

Share this post


Link to post
Share on other sites
12 hours ago, suenkachun said:

Dimensions Data for Part 30259 Triangular Sign W. Snap

Here is the real(?) dimensions; do not know if it's what you are looking for. Hope I help you.

Share this post


Link to post
Share on other sites
On 7/17/2022 at 12:08 PM, Eggyslav said:

I tried to upload a picture, but it's too big. Generally, the right leg has prints for both left and right legs, and they are doubled. What's weird tho, it only concerns bad batch decals, knights of ren prints are working correctly. As of the SC canopy, I see the problem has been resol

These are my leg prints, so everything seems to be fine?

templeg.jpg

Share this post


Link to post
Share on other sites
3 minutes ago, Stephan said:

These are my leg prints, so everything seems to be fine?

templeg.jpg

No problem on my end too. Hopefully, you had a chance to check the removed Part 2254 in the latest 220716.lxf file (I posted a file saved on my end earlier), I guess the other issues I mentioned can wait till the next update but do check the issues with 4261. For the Triangular Sign, I have decided to scan an actual copy of the Brick (I fortunately own one physical copy) and start from there, as the current Decorations all have gaps from the edges anyways and my custom designs are usually occupying the entire Sign without any gaps (the main thing to get right is the three curved corners of the Triangle then the rest of the details can be rescaled based on this, so the scan will help).

Share this post


Link to post
Share on other sites
On 7/18/2022 at 12:40 PM, marco9999 said:

Steering arm 4261's pegs do not connect to plate 4263's holes. Same issue with plates 2711, 4262, 4442 and 2719, as far as I know.

Fixed. But remember that those plates can no longer slide across 3673.

On 7/18/2022 at 3:17 PM, suenkachun said:

nly just had time to install the update, thanks for all the hard work! So far, everything seems to be working fine, but when I opened the latest 220716.lxf file, one of the Part 2654 got removed as a misplaced Brick.

Check if these files fix it for you? 

Share this post


Link to post
Share on other sites
Posted (edited)
10 minutes ago, Stephan said:

Check if these files fix it for you?

Unfortunately not, I guess you can check this file and compare it with yours, on my end there should have been two 2654 in the file but one got removed due to being placed incorrectly. I am trying to compare my file with your screenshot earlier but still cannot locate the missing 2654, If I do locate it I will post again.

Edited by suenkachun

Share this post


Link to post
Share on other sites
On 7/18/2022 at 3:17 PM, suenkachun said:

Another issue is with Part 32828. As shown below, try attaching it through a 85861 plus a 3062 beneath, and even after being adjusted the very tip may still collide with the 85861. If the 32828 is only attached to a 85861, at the moment we can’t push the 32828 all the way upwards.

Fixed

1 minute ago, suenkachun said:

Unfortunately not, I guess you can check this file and compare it with yours, on my end there should have been two 2654 in the file but one got removed due to being placed incorrectly. I am trying to compare my file with your screenshot earlier but still cannot locate the missing 2654, If I do locate it I will post again.

One should be located next to the AT-AT stickers, and the other (exactly the same) in the top left at the adjusted original parts section.

On 7/18/2022 at 3:17 PM, suenkachun said:

Also, if there is still time, could collisions be added to Part 35464 Slope 45 1x1 Double as this is the only newer Slope missing such data partially?

Fixed.

Share this post


Link to post
Share on other sites
3 minutes ago, Stephan said:

One should be located next to the AT-AT stickers, and the other (exactly the same) in the top left at the adjusted original parts section.

Found it, the one next to the AT-AT Stickers is missing since the two Flat Tile 2x6 got moved sideways causing the Flat Tile 1x1 to be moved too, thus deleting the 2654.

Share this post


Link to post
Share on other sites
Posted (edited)
On 7/18/2022 at 3:17 PM, suenkachun said:

P.S., can the Decoration Mapping Image or Dimensions Data for Part 30259 Triangular Sign W. Snap be shared as I’m hoping to finally add some custom Triangular Warning Signs to my projects? Thanks in advance!

This can just be a square with dimensions 512x512 or 1024x1024. As long as you color within the triangular part. Or use an existing decoration as example.

2 minutes ago, suenkachun said:

causing the Flat Tile 1x1 to be moved too

But for others the 2x6 tile was not moved...

Edited by Stephan

Share this post


Link to post
Share on other sites
Posted (edited)
2 minutes ago, Stephan said:

This can just be a square with dimensions 512x512 or 1024x1024. As long as you color within the triangular part.

No problem, I will retrieve the exact Triangle with my Brick scan and begin there (the curved angles need to be precise). The two Flat Tile 2x6 are only shifted in the latest 220716.lxf file but none of my existing models are affected.

Edited by suenkachun

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.