Recommended Posts

2 hours ago, Funnysh said:

Hello, can you add this part in next update please 

I'd love to, but there is no 3D model available.

Share this post


Link to post
Share on other sites
19 hours ago, M2m said:

Its not part of the Unity pack :(

Bummer, because it´s quite an awesome piece

Share this post


Link to post
Share on other sites
Posted (edited)

I'm currently working on adding in some of the updated magnet elements, but am running into an issue with the outline generation. Namely, despite the model UV shells being set up so that the edges should define the outlines (which is how LEGO does it, and I suspect/hope @polymaker does too), the outline generation ignores flat surface features, such as a border of the magnet and the magnet icon inlays. See the images below for more info. Can anyone tell what I may be doing wrong?

Magnet.thumb.jpg.d642ccad271f720f6adba361696f7748.jpg

Edited by ProfessorBrickkeeper

Share this post


Link to post
Share on other sites

@ProfessorBrickkeeper This is actually a "feature". My algorithm considers overlapped edges as fused. This is mostly to prevent generating outlines around decorable surface that are coplanar with non-decorable surfaces (e.g. the face of a minifigure head).

I plan to add more control over this process in brick studio but currently you will have to use a little trick (found by @Stephan IIRC):

Simply pull apart the model in brick studio so each surfaces to outline are separated, then generate the outlines and then put them back to their original positions.

 

Share this post


Link to post
Share on other sites

Bit of a problem. I just installed Stephan's new parts according to the instructions provided on the key topic, but when I opened up LDD, nothing appeared to have changed. I looked for some of the more recognizable new parts and couldn't find them, and when I pulled up some of the parts which had had new colorable areas added, they seemed to still be monochrome. The instructions were pretty simple, so I can't really think where I might have made a mistake, but I must have done so, right?

Share this post


Link to post
Share on other sites
4 hours ago, BrokenEye said:

Bit of a problem

Are you in Extended mode?

Share this post


Link to post
Share on other sites
Posted (edited)
I am using LDD 4.3. 11 and I download the files that Stephan puts, well I only downloaded the ones from the last post, but when I open the LDD all the bricks of my construction disappear, and I had to delete everything from the LEGO Digital Designer folder and reinstall the LDD that am I wrong?
Edited by Bony_em

Share this post


Link to post
Share on other sites
On 4/23/2021 at 12:15 AM, Stephan said:

Are you in Extended mode? 

Yeah. Though on further examination some new bricks have appeared, mostly in the first handful of categories, but only a very small minority of the ones listed on your thread.

Share this post


Link to post
Share on other sites

I can extract the ".rar" file but I am unable to get the new parts recognised by LDD. I am using LDD 4.3.11, is anyone able to help me troubleshoot please?

Share this post


Link to post
Share on other sites
Posted (edited)
14 minutes ago, The Mugbearer said:

@Anonknee Muss did you extract the db.lif and did you make sure that you merged the pack's and db's folders correctly?

The extraction was fine, it's the merging of folders I am getting stuck on. I am not sure what's going wrong. How did you extract the ".rar" out of curiosity?

Edited by Anonknee Muss

Share this post


Link to post
Share on other sites

 You download WinRar or a similar software that allows you to create and extract .rar, .zip and similar file formats.

Share this post


Link to post
Share on other sites
On 5/3/2021 at 5:33 PM, The Mugbearer said:

 You download WinRar or a similar software that allows you to create and extract .rar, .zip and similar file formats.

I made that far too. I'll take another shot either today or tomorrow. Thanks for your help.

Share this post


Link to post
Share on other sites
On 4/23/2021 at 12:15 AM, Stephan said:

Are you in Extended mode?

Ah, I have been a fool. The reasons the parts didn't show up is because the "Assemblies", "Decorations", "Primiitves" folders, etc. copied to C:\Users\[MY NAME]\AppData\Roaming\LEGO Company\LEGO Digital Designer\db\Primitives\db rather than C:\Users\[MY NAME]\AppData\Roaming\LEGO Company\LEGO Digital Designer\db. I moved them to the correct location and now everything seems to be working.

I've got a bunch of custom decals, so I'm probably going to have to merge the DecorationMapping.xml files manually. Any recommendations for how to handle this? I don't want to lose any of my custom decorations, but I also don't want to accidentally create any duplicate entries.

Share this post


Link to post
Share on other sites
Posted (edited)
6 hours ago, BrokenEye said:

I've got a bunch of custom decals, so I'm probably going to have to merge the DecorationMapping.xml files manually. Any recommendations for how to handle this? I don't want to lose any of my custom decorations, but I also don't want to accidentally create any duplicate entries

I'd say the easiest way is to leave some blank lines between the original lines and your lines with custom decorations. That way you can easily copy/paste your custom lines to the newest version of the DecorationMapping.xml file. 

Edited by Stephan

Share this post


Link to post
Share on other sites

But how to make the new db.lif file? I know, in lifcreator, but how?

Share this post


Link to post
Share on other sites
5 minutes ago, Stephan said:

I'd say the easiest way is to leave some blank lines between the original lines and you lines with custom decorations. That way you can easily copy/paste your custom lines to the newest version of the DecorationMapping.xml file. 

Perfect. I was hoping it'd be something simple like that, but you never can be to careful.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.