Recommended Posts

Hi,

I have part snapping enabled in LDCAD but no parts are longer automatically snapping in place.

How to fix this?

Share this post


Link to post
Share on other sites

Most probably you have a library configuration issue, and LDCad can't find the shadow library which defines connectivity. Look at prefs->ldraw->search library paths. Default shadow library (with default installation) is %appdata%\LDCad\shadow\offLib\offLibShadow.csl

Share this post


Link to post
Share on other sites

A couple of things are needed for snapping to work:

- Correctly configured shadow libraries (By default one is installed and configured automatically for the official LDraw library).

- Use of these shadows must be enabled (prefs/shadow files), is enabled by default but I noticed some people have (accidentally) disabled that option for some reason.

- Part snapping must be enabled in the editing session, controlled trough the compass or shift+p

- The parts you want to snap must have information in the shadow library which isn't the case for all parts yet as I have 'only' defined snapping info for about half (about 95% of daily use parts though) of the official parts.

If with this all checked not even a 2x4 brick will snap, then something else is at play, you could try:

Resetting the configuration, by deleting %appdata%/LDCad/config/main.cfg while the program is closed. The program will then reask the ldraw library location at next start and will set all defaults again.

If this doesn't work I would need a log file to see if the shadow etc is actually loaded and applied.

please mail the contents of (preferentially after open a random model in LDCad first)

%appdata%/LDCad/logs

ps: There might also be a upgrade bug at play as I had some other people with this problem for whom it at first did work. What version did you install (AIOI, setup, archive, win/linux etc).

Hope this helps

 

Edited by roland

Share this post


Link to post
Share on other sites

Hi

I tried adding C:\Users\kris\AppData\Roaming\LDCad\shadow\offLib\offLibShadow.csl

and also enabled shadows, The other settings were fine.

Still nothing, so I deleted main.cfg and opened LDCAD again and selected C:\ldraw as the parts library. Still nothing.

Here is my log file.

 

Regards, Snipe

Edited by SNIPE

Share this post


Link to post
Share on other sites

The log indicates the shadow file is loaded and used, you can see this for example here:

27424 | 2017-11-25_01:18:09 | Progress | render prep | C:\ldraw\parts\4490.dat | Starting
27425 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | Raw data has 1272 potential vertices (tri 80; quad 100; norLine 184; conLine 66)
27426 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | Mesh reduced to 347 vertices (27.28% of org)
27427 | 2017-11-25_01:18:09 | Progress | render prep | C:\ldraw\parts\4490.dat | Generating normals / smoothing geometry
27428 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | Generated 347 normals
27429 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | Mesh inflated to 519 vertices (40.80% of org)
27430 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | All recursive data has valid BFC information, part will be rendered with culling enabled.
27431 | 2017-11-25_01:18:09 | Info     | render prep | C:\ldraw\parts\4490.dat | Subfile has 5 snap info points.
27432 | 2017-11-25_01:18:09 | Progress | render prep | C:\ldraw\parts\4490.dat | Done

This is the 1x3 arch brick wich reported 5 snap points (3 on top 2 on bottom).

I think this being the first boot after a config reset you probably forgot to enable snapping in the editing session (as it is disabled by default). Change 'GS' into 'PS' inside the compass at the left bottom corner.

ps: I think you are using an older library as there are many warnings on some parts I think have been fixed/resolved in later library versions. The shadow is maintained to work best with the latest library.

Edited by roland

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.