wooootles

LDD 4.3.9 advanced shading broken in my PC

Recommended Posts

Hey all,

I encountered this in my new computer; when I open a large file (large being as small as a 32x16 modular building design), I get this funky image when I turn on outlines/advanced shading. Little CITY car size files open ok.

Any ideas on how I can fix this, besides turning the shading off? (it's a huge help to build with oulines/advanced shading). I know it's not particularly a 4.3.9 bug since the file opens with no problems on my other older computers.

It's a fairly new PC, i7-6700k, Nvidia GTX 1070 and 16GB RAM, with drivers updated. Also, using Intel integrated graphics also doesn't produce an image like this.

Help is appreciated! Thanks

28730132561_e20d564dca_c.jpg

Edited by wooootles

Share this post


Link to post
Share on other sites

Hmm, you said graphic drivers are updated? How are the card's temperatures and voltages? Did you OC it?

Share this post


Link to post
Share on other sites

Yeah, Nvidia 368.81, and for the purposes of finding the problem everything is stock (CPU and GPU). Temps are around 37-40 C when spinning the LDD model around and such, so I don't think that's the issue either.

I just put this computer together 3 days ago.

Share this post


Link to post
Share on other sites

Hi, I am also having this exact same issue. I upgraded my computer a few months ago from Windows 7 with an nVidia 660ti graphics card to Windows 10 with an nVidia 1080. I can't seem to figure what exactly is triggering this issue; graphics card, OS, LDD, OpenGL, etc... I have tried installing older versions of the nVidia driver, but no luck. I also tried running it inside a virtual machine with Windows XP, I don't get the messed up triangles but the vast majority of the parts are missing somehow. I figure the virtual machine software still uses the same OpenGL/video card acceleration for the rendering... The odd thing is if I select the entire model and try moving it around, the model appears correctly during that operation.

I'm hoping you've had luck fixing this issue as I really can't work without the brick outlines. In your initial post, you mentioned advanced shading, do you also get the problem without the brick outlines or only when that option is activated like on my PC?

Share this post


Link to post
Share on other sites

I find it hard to believe nobody else is experiencing this. I tried LDD (4.3.10) at my friend's place and he has a 1070. Same issue... actually all I had to do was put two large plates together and this issue started. He is also running on Windows 10, but I have a feeling this is related to something with the nVidia series 10 cards or software/drivers.

Is anybody else experiencing this? I really need this to work as LDD is completely useless to me without this.

Share this post


Link to post
Share on other sites

Unfortunately I think it's gotta be a driver issue with the GTX10XX line. I myself built a new computer earlier this year running  Win7 on an Intel 6600K and 16 GB Ram, but I got a GTX 750 Ti to tide me over until I can get a 1080 next year (They weren't out yet when I built it). It seems the common denominator on effected machines is the 10XX line... I guess that's something for me to keep in mind next year!

Do you have another video card you can swap in and see if that solves the problem?

Edit again: Just had a friend with a GTX 1080 try it out, they're running an older Intel CPU. Same problem shows up as soon as they turn on the outlines, but no problem without. Perhaps you could try running without outlines and see if that solves it for you?

Edited by Daedalus304

Share this post


Link to post
Share on other sites

Looks like I missed your reply. Thanks for the information.

Most of my drawings are rather large and complex, I really can't work without the outlines. As for swapping out the card, I thought about it but didn't want to deal with opening the computer every time I want to switch between LDD and other stuff. But it made me think, I wonder if I could get away with those USB video cards, I probably wouldn't get 3D acceleration but perhaps my computer would be fast enough. Hopefully this gets resolved fast as I've basically put all my creations on hold.

Thanks again

Nic

Share this post


Link to post
Share on other sites

Hi,

I just installed a GTX 1060 and experience the exact same problem. This is the first forum I read about other people having the same issue. I also reinstalled my drivers two times but it didn't solve anything. 

The only work around for now is turning off 'Outline on bricks' and I increased the level of advanced shading to "compensate".

I hope it gets fixed as soon as we find out where the problem lies because I design 10.000+ bricks models and I bought the graphics card to help LDD. Working without the outlining is difficult in large designs. 

Share this post


Link to post
Share on other sites

I thought I was the only one having this problem (I missed this topic), but apparently not. I'm also using a GTX 1070.
I think it has something to do with the drivers and not with LDD, since only 10XX cards from Nvidia seem to have this problem.

I filed a driver bug report at Nvidia's website. I hope they'll (try to) do something about this. I mean, it's quite a niche problem :sweet:
I think the only thing we can do is bring this to Nvidia's attention (unless it's of course a LDD bug or something, but that seems quite unlikely).

Share this post


Link to post
Share on other sites

I'm glad more people are encountering the issue. The more exposure the better chance it has of getting resolved. I tried changing the 3D settings through the NVidia Control Panel, but no luck, I couldn't find a setting that affected the issue. On a side note, I have been using the following settings to improve the visual quality of the bricks in the bricks picker/pane:

Antialiasing - Mode: Override any application setting

Antialiasing - Setting: 8x

Thanks for filing a bug report. I didn't realize this could be done.

3D Settings.png

Share this post


Link to post
Share on other sites

Same issue here. Notice that this is exclusive to GTX 10XX series, since GTX 9XX worked just perfectly.

Share this post


Link to post
Share on other sites
On 20-11-2016 at 8:04 AM, teknix1 said:

I'm glad more people are encountering the issue. The more exposure the better chance it has of getting resolved. I tried changing the 3D settings through the NVidia Control Panel, but no luck, I couldn't find a setting that affected the issue. On a side note, I have been using the following settings to improve the visual quality of the bricks in the bricks picker/pane:

Antialiasing - Mode: Override any application setting

Antialiasing - Setting: 8x

Thanks for filing a bug report. I didn't realize this could be done.

3D Settings.png

If I go into my Nvidia settings, Antialiasing Mode is greyed out for LDD. How did you manage to change that ? 

Share this post


Link to post
Share on other sites

Hello people! 

I'm having this exact same issue and had been bugging LEGO support about it until they redirected me to this forum!

I'm using a GTX1070 by Asus and as soon as I enable brick outlines, the drawing gets messed up. Even if you only place a single large tile (like those at the base of the Eiffel Tower) the graphics get scrambled. 

I tried it on my work computer which has a really old graphics card but the issue isn't there. 

Has anyone found a solution?

Share this post


Link to post
Share on other sites
2 hours ago, Legorides said:

If I go into my Nvidia settings, Antialiasing Mode is greyed out for LDD. How did you manage to change that ? 

That's odd. I'll have to check later when I get home. Are you able to change anything else? I really didn't do anything special here. Just went to the program settings tab, added the ldd executable to the list. You should then be allowed to change every setting. 

37 minutes ago, NastyPirate said:

Hello people! 

I'm having this exact same issue and had been bugging LEGO support about it until they redirected me to this forum!

I'm using a GTX1070 by Asus and as soon as I enable brick outlines, the drawing gets messed up. Even if you only place a single large tile (like those at the base of the Eiffel Tower) the graphics get scrambled. 

I tried it on my work computer which has a really old graphics card but the issue isn't there. 

Has anyone found a solution?

I don't believe anyone has a fix yet. One thing I wanted to try was to use a USB graphics adapter instead. I just don't know how much 3D acceleration those have. I fear it completely relies on the CPU for that. So it may not be a great solution in the end. 

Larger plates seem to be worse. If I really have to do something with LDD, I often end up moving plates out after I connected them. Definitely harder to work that way, but I can't use the software without the outlines. I've put all my projects on hold because of this. 

Share this post


Link to post
Share on other sites
2 hours ago, teknix1 said:

I don't believe anyone has a fix yet. One thing I wanted to try was to use a USB graphics adapter instead. I just don't know how much 3D acceleration those have. I fear it completely relies on the CPU for that. So it may not be a great solution in the end. 

Larger plates seem to be worse. If I really have to do something with LDD, I often end up moving plates out after I connected them. Definitely harder to work that way, but I can't use the software without the outlines. I've put all my projects on hold because of this. 

I don't think you should go to that extent using a USB graphics adapter. Since all the previous generation GPUs work properly, clearly it's an issue with the Pascal cards' drivers. I posted on an nvidia thread about it and we'll see. 

I was using LDD without the outlines until I discovered its existence :P

Share this post


Link to post
Share on other sites

Legorides, I just had a look in my settings, everything is open. Are you on the "Global Settings" tab by any chance? If you can, perhaps try restoring the default settings. I suspect your are running the latest drivers. I don't know what else it could be...

6 hours ago, NastyPirate said:

I don't think you should go to that extent using a USB graphics adapter. Since all the previous generation GPUs work properly, clearly it's an issue with the Pascal cards' drivers. I posted on an nvidia thread about it and we'll see. 

I was using LDD without the outlines until I discovered its existence :P

Any chance you could post the link to the nVidia thread, if the rules on eurobrick allows it? I would really like to follow it as well. Could this problem also be with LDD itself?

As for working without the outlines, I don't know how you do it, to me that's like an itch you can't scratch... :)

Share this post


Link to post
Share on other sites
5 hours ago, teknix1 said:

Any chance you could post the link to the nVidia thread, if the rules on eurobrick allows it? I would really like to follow it as well. Could this problem also be with LDD itself?

As for working without the outlines, I don't know how you do it, to me that's like an itch you can't scratch... :)

Yes it's here:

https://forums.geforce.com/default/topic/955163/?comment=5038342

 

Only me and the initial person have written in it... maybe if we get many they will notice.

Share this post


Link to post
Share on other sites
On 15-12-2016 at 11:57 PM, teknix1 said:

Legorides, I just had a look in my settings, everything is open. Are you on the "Global Settings" tab by any chance? If you can, perhaps try restoring the default settings. I suspect your are running the latest drivers. I don't know what else it could be...

Any chance you could post the link to the nVidia thread, if the rules on eurobrick allows it? I would really like to follow it as well. Could this problem also be with LDD itself?

As for working without the outlines, I don't know how you do it, to me that's like an itch you can't scratch... :)

Sorry for the late respons, busy times at work. With updating my drivers to 376.33 I also reset everything from changes and now I'm able to alter all the settings. 

However, the problem still isn't fixed. I'm afraid it'll be up to Lego ? 

Share this post


Link to post
Share on other sites
23 minutes ago, Legorides said:

Sorry for the late respons, busy times at work. With updating my drivers to 376.33 I also reset everything from changes and now I'm able to alter all the settings. 

However, the problem still isn't fixed. I'm afraid it'll be up to Lego ? 

I'm afraid it's probably up to lego to make a patch to support the new Pascal architecture or something... but without support no future.

Share this post


Link to post
Share on other sites

Would be nice to get some feedback from LDD users who invested in the new AMD RX series. Would be weird if it was just an Nvidia problem...

Share this post


Link to post
Share on other sites
8 hours ago, Legorides said:

Would be nice to get some feedback from LDD users who invested in the new AMD RX series. Would be weird if it was just an Nvidia problem...

That wouldn't be weird at all. I think the problem really is Nvidia GTX 10xx only, otherwise we would've heard AMD users complaining already I think.

Share this post


Link to post
Share on other sites

Yeah i have this too, any update from LDD crew about this? I doubt nvidia will fix it unless its related to something quite serious.

Share this post


Link to post
Share on other sites

I have the same Problem and a 1070 by MSI GAMING built into my pc. I wrote a email to LEGO. Lets see what they answer

Edited by KikoTube

Share this post


Link to post
Share on other sites
On 4-2-2017 at 11:23 AM, KikoTube said:

I have the same Problem and a 1070 by MSI GAMING built into my pc. I wrote a email to LEGO. Lets see what they answer

Hi, sorry to kick this rather old topic, but did you ever receive an answer ? I just updated Geforce drivers, problem is still there. 

Perhaps anybody have some clue on this? 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.