Jim

BuWizz - High Performance LEGO Power Functions Controller and Battery

Recommended Posts

7 hours ago, kbalage said:

BuWizz 2.0 works perfectly fine with BrickController 2 and game controllers. Hopefully the BuWizz team will have time soon to share the details of the protocol used for 3.0 and it can also be included in the app.

Awesome, thanks!  I had no idea - I had been away from Technic for years and am trying to get caught up on the third party hardware and software developments.

Share this post


Link to post
Share on other sites

Great work Buwizz team! I'm very pleased with the finished product. Totally worth the wait and money! Both the Bricks 3.0 and the motors work great! Center steer module for using powered up motors for steering works well too! Goodbye PF servos! However, the 12V power does require you to be careful. Gears are easily stripped and universal joints easily destroyed. Gonna have to stock up!

Share this post


Link to post
Share on other sites

Just got a second 3.0 (2 day delivery was on point) and found with the right gearing it is possible to get 7 amps combined (when using both outputs) and about 4.5 amps (single channel). But when it goes over 4 amps it reads as 0 amps (4.5 amps shows 0.5 amps).

When charging (from a laptop) it takes hours to get the green light to stop flashing is this normal or am I overcharging?

Share this post


Link to post
Share on other sites
3 hours ago, Aerolight said:

Just got a second 3.0 (2 day delivery was on point) and found with the right gearing it is possible to get 7 amps combined (when using both outputs) and about 4.5 amps (single channel). But when it goes over 4 amps it reads as 0 amps (4.5 amps shows 0.5 amps).

When charging (from a laptop) it takes hours to get the green light to stop flashing is this normal or am I overcharging?

Laptops&PCs provide VERY low current (~500mA) hence such slow charging speed. It is much better to use your smartphone's charger, which is most likely rated at much higher current value (also BuWizz 3.0 supports Quick charge according to their website, which most modern chargers also provide). 

Edited by syclone

Share this post


Link to post
Share on other sites

After some tests, i found that:
-One of my bricks have issues with one port, and sometimes it doesn't work at all. The motor is fine (I tried with few different models with the very same result and tested that the motors works fine with the Lego technic hub).

-After connection, but not moving anything the motors are still moving slightly. It is particularllly visible with the large angular motor. The moves are for and backwards and very small, but clear. 

Has someone else experienced something similar?

Share this post


Link to post
Share on other sites
6 hours ago, HectorMB said:

After some tests, i found that:
-One of my bricks have issues with one port, and sometimes it doesn't work at all. The motor is fine (I tried with few different models with the very same result and tested that the motors works fine with the Lego technic hub).

-After connection, but not moving anything the motors are still moving slightly. It is particularllly visible with the large angular motor. The moves are for and backwards and very small, but clear. 

Has someone else experienced something similar?

On my 2.0 I have seen that occasionally, connected motors make small back and forth motions (much less than a full rotation each way).  I haven't seen any pattern to the behavior.

Share this post


Link to post
Share on other sites

I'd be happy to order a Buwizz 3.0 and a few motors, but I have been a bit discouraged by the issues people are reporting here (especially problems with steering, port not working). @Zerobricks, what is the status of these issues? Were they confirmed? Is it known if there are HW bugs, or only SW problems that may be fixed later? Does the app release contain some fixes as well?

Share this post


Link to post
Share on other sites
6 hours ago, ScT said:

May be worth getting your order in now if you were thinking of buying one, there's a price increase occurring. In other news, the app will be updated, too. More info: https://buwizz.com/buwizz-brick-price-increase-and-new-app-release/

It's too bad about the price increase, but I respect their right and reasons to do so. It's already too expensive for me to justify, so I guess it won't really affect me anyways!

Share this post


Link to post
Share on other sites
On 9/18/2021 at 5:16 PM, gyenesvi said:

I'd be happy to order a Buwizz 3.0 and a few motors, but I have been a bit discouraged by the issues people are reporting here (especially problems with steering, port not working). @Zerobricks, what is the status of these issues? Were they confirmed? Is it known if there are HW bugs, or only SW problems that may be fixed later? Does the app release contain some fixes as well?

We are working on adding more functionality to the center-steer module and the gearbox module. I should have an internal version of the application soon which I will use to set up the best default steering parameters for various official models. Parameters like initial center steering power (PWM) PID values of the controller and more.

Edited by Zerobricks

Share this post


Link to post
Share on other sites
4 hours ago, Zerobricks said:

We are working on adding more functionality to the center-steer module and the gearbox module. I should have an internal version of the application soon which I will use to set up the best default steering parameters for various official models. Parameters like initial center steering power (PWM) PID values of the controller and more.

Thanks for the info. So these seem like software issues that can be fixed. What's with the port not working issue? Did you manage to replicate/debug that? Is that possibly a HW issue?

BTW, can the firmware be updated on a BuWizz? Is the application capable of doing so if needed in the future?

Share this post


Link to post
Share on other sites

When specific questions about solving problems are answered in this way, there are even more questions. I think for many people there is a dilemma of buying Buwizz 3.0 right now with the possibility of getting hardware problems, or not buying it at all. Since the price will be too high (including the risk of getting a problematic device).

An adequate approach would be to solve all the problems first, open protocols to third-party applications so that there is accurate clarity about the device, and only then raise the price of the device itself.

Edited by Igor1

Share this post


Link to post
Share on other sites
2 hours ago, gyenesvi said:

Thanks for the info. So these seem like software issues that can be fixed. What's with the port not working issue? Did you manage to replicate/debug that? Is that possibly a HW issue?

BTW, can the firmware be updated on a BuWizz? Is the application capable of doing so if needed in the future?

The port issues seem to be caused by the custom connectors, but they are easy to fix, even by the end-user with a simple needle to pull out the contacts out a bit. Of course they will be corrected in the next batch of connectors.

Yes, firmware can be updated, we are in process of identifying bugs and correcting them for BuWizz 3.0 and eventually for 2.0 to bring functions such as wake to shake and rename to BuWizz 2.0 too.

2 hours ago, Igor1 said:

When specific questions about solving problems are answered in this way, there are even more questions. I think for many people there is a dilemma of buying Buwizz 3.0 right now with the possibility of getting hardware problems, or not buying it at all. Since the price will be too high (including the risk of getting a problematic device).

An adequate approach would be to solve all the problems first, open protocols to third-party applications so that there is accurate clarity about the device, and only then raise the price of the device itself.

I can't talk about the price raises, since that's not my domain but I personally am working hard on identifying and fixing problems and of course pushing hard to have the protocol edited to be more user-firendly and released. But there are are lot exterior factors and partners to manage which take patience and time.

Share this post


Link to post
Share on other sites
11 hours ago, Zerobricks said:

The port issues seem to be caused by the custom connectors, but they are easy to fix, even by the end-user with a simple needle to pull out the contacts out a bit. Of course they will be corrected in the next batch of connectors.

But thanks a lot for such frankness! At least some clarity with the connectors.

Share this post


Link to post
Share on other sites
On 9/20/2021 at 12:41 AM, Zerobricks said:

The port issues seem to be caused by the custom connectors, but they are easy to fix, even by the end-user with a simple needle to pull out the contacts out a bit. Of course they will be corrected in the next batch of connectors.

Thanks, so if I order one now, would that already come with the new batch of connectors or not yet?

Share this post


Link to post
Share on other sites

@Zerobricks, the BuWizz 3 seems to have gone out of stock, I can't order it. Does this mean that I won't be able to order it with the current price?

Share this post


Link to post
Share on other sites
22 minutes ago, gyenesvi said:

@Zerobricks, the BuWizz 3 seems to have gone out of stock, I can't order it. Does this mean that I won't be able to order it with the current price?

Sorry, marketing and sales is not my domain, please turn to support.

Share this post


Link to post
Share on other sites

I tried to buy a BuWizz 3 today, using a discount voucher they'd sent me after the long delays with the buwizz motors, and was told 'Unfortunately, it is not valid for products on sale or in line for the price increase, like BuWizz 3.0 Pro and BuWizz 2.0.'

Share this post


Link to post
Share on other sites

After contacting the customer service about the 2 issues i have (the for-backwards move and the temporary deconexion of one port), i was told that:
-the updated app will take (or try to) care of the control of the larga angular motor
-And that the deconexion in the ports might be due to defectuous contact in the BuWizz brick.

Now, de "temporal" deconexion is not anymore temporal but permanent. Tried to pull a bit the contacts but with no improvement. I contacted fr customer service again to see what to do now. 

Regarding the increase of price; well I have no objection if the current situation made the old prices unsustanable. Nevertheless, given the issues coming from the BuWizz 3.0 and the still-to-come app, I think such increase comes in not the best moment. Honestly, when I saw the increase of prices I considered (almost 100%) to get 1 or 2 BuWizzes more, but as the ones that I already have are not working properly, I decide not do order anything else. I am afraid that my action-reaction is similar to many of those that were thinking to get some bricks before the increase of price. 

But also, regarding the impossibility of using the discount given for our patience for the first delivery of the BuWizzes 3.0 for getting BW 2.0 or BW 3.0... I just don't get it.  

Share this post


Link to post
Share on other sites
18 hours ago, HectorMB said:

Regarding the increase of price; well I have no objection if the current situation made the old prices unsustanable. Nevertheless, given the issues coming from the BuWizz 3.0 and the still-to-come app, I think such increase comes in not the best moment. Honestly, when I saw the increase of prices I considered (almost 100%) to get 1 or 2 BuWizzes more, but as the ones that I already have are not working properly, I decide not do order anything else. I am afraid that my action-reaction is similar to many of those that were thinking to get some bricks before the increase of price.

I agree.

I think BuWizz in a hurry released the first batch of 3.0 devices with problematic ports and now they don't even want to sell them (the current status is "Out of stock"). Apparently, with the current price for the device, fixing the problem is also not cost-effective. The situation is sad. I really hope that after a while everything will be fine.

Edited by Igor1

Share this post


Link to post
Share on other sites
21 minutes ago, HectorMB said:

After contacting the customer service about the 2 issues i have (the for-backwards move and the temporary deconexion of one port), i was told that:
-the updated app will take (or try to) care of the control of the larga angular motor
-And that the deconexion in the ports might be due to defectuous contact in the BuWizz brick.

Now, de "temporal" deconexion is not anymore temporal but permanent. Tried to pull a bit the contacts but with no improvement. I contacted fr customer service again to see what to do now. 

Regarding the increase of price; well I have no objection if the current situation made the old prices unsustanable. Nevertheless, given the issues coming from the BuWizz 3.0 and the still-to-come app, I think such increase comes in not the best moment. Honestly, when I saw the increase of prices I considered (almost 100%) to get 1 or 2 BuWizzes more, but as the ones that I already have are not working properly, I decide not do order anything else. I am afraid that my action-reaction is similar to many of those that were thinking to get some bricks before the increase of price. 

But also, regarding the impossibility of using the discount given for our patience for the first delivery of the BuWizzes 3.0 for getting BW 2.0 or BW 3.0... I just don't get it.  

Just FYI I'm the person behind the technical support and I will have your BuWIzz with contacts issues replaced.

As said before I can't comment on the prices, and discounts but the fact is we are having issues with procurement of semiconductor elements as is much of the electronic industry.

In other news we are planning to release the control protocol for BuWIzz 2.0 and 3.0 in the following days.

Share this post


Link to post
Share on other sites
11 minutes ago, Zerobricks said:

Just FYI I'm the person behind the technical support and I will have your BuWIzz with contacts issues replaced.

As said before I can't comment on the prices, and discounts but the fact is we are having issues with procurement of semiconductor elements as is much of the electronic industry.

In other news we are planning to release the control protocol for BuWIzz 2.0 and 3.0 in the following days.

Good to know, thanks! I was aware that you belonged to the team, but did not know where exactly.

I will do the do tests on the other BuWizz (hope that it doesn't need replacement), and I will let you know. 

Also, @Zerobricks, you are putting a lot of effort here in the forum to cope with all the comments that arise, and I truly appreciate it. Really. Puting aside the price thing, the BW are nice products, above the performance delivered by TLG, and I am happy with them. Nevertheless, until we can see, test and enjoy the updated app is difficult to say if the BW 3.0 worth the money. I am truly looking forward the capabilities of the BW 3.0 with the appropriate app. 

And now that you mentioned about the replacement: I am wondering that, as you said that this issue will be fixed in the new batch of ports, will have the replacement BWs the "fixed" ports, or they will be repaired with the same type/batch of port? 

Edited by HectorMB

Share this post


Link to post
Share on other sites
2 minutes ago, HectorMB said:

Good to know, thanks! I was aware that you belonged to the team, but did not know where exactly.

I will do the do tests on the other BuWizz (hope that it doesn't need replacement), and I will let you know. 

Also, @Zerobricks, you are putting a lot of effort here in the forum to cope with all the comments that arise, and I truly appreciate it. Really. Puting aside the price thing, the BW are nice products, above the performance delivered by TLG, and I am happy with them. Nevertheless, until we can see, test and enjoy the updated app is difficult to say if the BW 3.0 worth the money. I am truly looking forward the capabilities of the BW 3.0 with the appropriate app. 

I'm really grateful for the positive feedback, just trying my best to be as helpful and transparent as possible.

In case your motor does not work in servo mode on other BuWizz brick either, that could mean you have a bad motor, we already had a case like that.

Share this post


Link to post
Share on other sites

Regarding the motor, that was there first thing that I checked. The motor works perfectly fine in standard Lego hubs and other motors have the same issue in that BW brick. 

Do you know if the repair/substitution of the BW will be with new ports to prevent this issue reoccurrence?

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.