Recommended Posts

Ah thanks a lot.

Thats what i was looking for

Did not find in Google Play  store

Edited by Lok24

Share this post


Link to post
Share on other sites

Seems that this Info isn't correct

Obviously only v1.1 may be installed with android 4.3.

But App Version is 2.6.

 

Share this post


Link to post
Share on other sites
6 minutes ago, Lok24 said:

Seems that this Info isn't correct

Obviously only v1.1 may be installed with android 4.3.

But App Version is 2.6.

 

Hmkay. Google Playstore sais: 4.4 for BrickController 2.6

Github page needs an update ;)

Share this post


Link to post
Share on other sites
1 hour ago, Gimmick said:

Hmkay. Google Playstore sais: 4.4 for BrickController 2.6

I don't find any hint in playstore...

Share this post


Link to post
Share on other sites

@imurvai Hi István, today I finally got me a USB OTG cable so I hooked up my PS3 Dualshock controller to my phone (I do not want to root my employers phone, so I went for a wired setup). All works fine except for 1 button (= PS3 controller issue, not an app issue), but when I disconnect the controller from cable/phone before closing the app, the app crashes (instead of giving a notification 'controller connection lost' or something like that). It is not a big issue and no harm is done anywhere, but I just thought I'd let you know.

  • BC app version is 2.6
  • Phone is Samsung S7 (G930-F)
  • Android version 8.0.0

If you need more info, let me know. I can reproduce the issue.

Edited by Rudivdk

Share this post


Link to post
Share on other sites
1 hour ago, Rudivdk said:

@imurvai Hi István, today I finally got me a USB OTG cable so I hooked up my PS3 Dualshock controller to my phone (I do not want to root my employers phone, so I went for a wired setup). All works fine except for 1 button (= PS3 controller issue, not an app issue), but when I disconnect the controller from cable/phone before closing the app, the app crashes (instead of giving a notification 'controller connection lost' or something like that). It is not a big issue and no harm is done anywhere, but I just thought I'd let you know.

Thanks for the info. To be honest I haven't tried with wired controllers.

6 hours ago, Lok24 said:

Seems that this Info isn't correct

Obviously only v1.1 may be installed with android 4.3.

But App Version is 2.6.

This is something I forgot to update on the github site, sorry for that. Originally the requirement was Android 4.3 but in the meantime I started using an external library requiring Android 4.4.

Share this post


Link to post
Share on other sites
1 hour ago, Lok24 said:

In German description  this Info is missing....

It looks like it's missing in the Playstore-App, website in browser shows it - for me in german.

Share this post


Link to post
Share on other sites

i have a problem with a new build that i did and used the new technic hubs..  

when accelerating the engines cuts out aver 2-4 sec and you have to let go of the button and then press down again.  

was thinking if it is maybe some wrong with the hub but it seems to work fine as when i make a small code in Powered up app (thank you racingbrick for the help) it just keeps going and going.  the same problem is without any load on the motors. 

 

it is wierd because it works good in the 42099 

Share this post


Link to post
Share on other sites

Awesome app! I have been recommending my friends to use this. One suggestion though, is it possible to add a import/export the config for mapping etc?

 

Like I setup the controller profile for Liebherr on phone A, then export it to somewhere (cloud or google drive) then import the profile on my iPad and launch and start playing?

Share this post


Link to post
Share on other sites

I second that, it'd be an awesome feature to have. For example, the phone I'm using for LEGO RC is failing and I'd like to transfer my profiles to another instead of having to recreate them.

Share this post


Link to post
Share on other sites
7 hours ago, ChrisLim83 said:

One suggestion though, is it possible to add a import/export the config for mapping etc?

Yeah, it has been requested by many people and I'm investigating how it could be added. I'm on it...

Share this post


Link to post
Share on other sites
15 hours ago, imurvai said:

Yeah, it has been requested by many people and I'm investigating how it could be added. I'm on it...

Awesome!! Really appreciate this app.

Somehow my liebherr just REFUSES to connect to the Control+ app, but connects to BrickController and other Apps just fine😒

The batmobile is also so much more fun with a physical controller

Share this post


Link to post
Share on other sites
7 hours ago, ChrisLim83 said:

Somehow my liebherr just REFUSES to connect to the Control+ app, but connects to BrickController and other Apps just fine😒

Two common reasons: the motors are not exactly and properly connected in the correct(!) ports to the Hubs, or Power On sequence is wrong.

Share this post


Link to post
Share on other sites
4 hours ago, Lok24 said:

Two common reasons: the motors are not exactly and properly connected in the correct(!) ports to the Hubs, or Power On sequence is wrong.

Power on sequence is correct, as the bottom hub connects just fine. Its the top hub that blinks, turn blue, blinks, turn blue and keep repeating

Share this post


Link to post
Share on other sites
24 minutes ago, AVCampos said:

Doesn't the app ask you to connect the top hub before the bottom one?

Normally it should not matter, it connects with either hubs first. As it was suggested previously you need to double check the ports where the motors are connected, they need to match exactly the instructions.

Share this post


Link to post
Share on other sites
On 1/8/2020 at 7:38 PM, imurvai said:

Yes, I'm also experiencing lags and halts, so I'm on it...

I have lags now, too.

I tried two different settings with PoweredUp Technic Hub + Samsung Galaxy A5 + XBOX Gamepad:

  1. Speed on left analog stick, steering on right analog stick -> Huge lags sometimes.
  2. Speed on analog shoulder keys (foward right key, backwards left key) and steering on right analog stick -> no lags for now (but the car sometimes steers without any input, but that seems to be a Lego problem)

Maybe this info helps somehow, I will try a few more things tomorrow.

Share this post


Link to post
Share on other sites

Forgive me for not going through 33 pages, so I hope the Admin doesn't mind me asking :wink: :tongue:

Can I use any controller which can be connected to iOS? Or are there limitations? This piece of software looks like it could be my solution.

Can I use an XBox 360 controller?

Share this post


Link to post
Share on other sites
Just now, Jim said:

Forgive me for not going through 33 pages, so I hope the Admin doesn't mind me asking :wink: :tongue:

Can I use any controller which can be connected to iOS? Or are there limitations? This piece of software looks like it could be my solution.

Can I use an XBox 360 controller?

Hi @Jim,

For iOS you need an MFI compatible controller or a Sony PS4 or an XBox One gamepad. As far as know the XBox 360 is not compatible with iOS.

Share this post


Link to post
Share on other sites
Just now, imurvai said:

Hi @Jim,

For iOS you need an MFI compatible controller or a Sony PS4 or an XBox One gamepad. As far as know the XBox 360 is not compatible with iOS.

XBox One or PS4 is even better! Is that simply a matter of connecting them via BT directly to the iPad?

Share this post


Link to post
Share on other sites
3 minutes ago, Jim said:

XBox One or PS4 is even better! Is that simply a matter of connecting them via BT directly to the iPad?

Yes, once they are paired with iOS BC2 automatically can use it.

Share this post


Link to post
Share on other sites
4 minutes ago, imurvai said:

Yes, once they are paired with iOS BC2 automatically can use it.

Cool!

I am finishing my review for the crawler as we speak, so I will probably include this in my review :thumbup:

Share this post


Link to post
Share on other sites

The user interface is not as intuitive as I like it to be, but I did manage to get things up-and-running in no time. Very cool app.

The lag is a bit annoying, but it's inevitable with these kind of solutions. Overall I absolutely like the options this app gives us.

And since the code is Open Source, I might do some tinkering myself.

Thanks @imurvai for creating this wonderful solution and making the source code available :wub:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.