Recommended Posts

Would it be possible to make the app work even with locked touchscreen? I would like to have phone locked and placed in pocket. 

I really enjoy the app, it is much better IMHO than all official apps. 

Share this post


Link to post
Share on other sites

Two of my suggestions for the app:

1) Make the play screen "dark mode" (use black background instead of white) in order to preserve battery for those having OLED displays. Or even better enable a dark theme for the entire app.

2) For BuWizz 2, in the play screen, make the Ludicrous mode optional. That is, in the  Buwizz 2 device settings add a toggle button for the Ludicrous mode button to be displayed or not in the play screen. That's because some 9V devices connected to BuWizz may not support the 12V delivered by the Ludicrous mode, like an IR receiver supplied from the BuWizz port, and I would like not to accidentally enable it from the play screen.

Share this post


Link to post
Share on other sites

Hi,

I still experience the same issue with the servo getting stuck with 2.5 on Android. Interestingly, it also seems to effect SBrick. Going back to 2.3 seemed to have solved that, I haven't been able to get either the SBrick of the PU stuck since I downgraded. 

Another issue I see while using the new L motor as a servo is that it's output is really "choppy", on both 2.3 and 2.5. I don't really see this when controlling from the Control+ app. 

This video was recorder with BC 2.5, both issues are apparent:

 

Share this post


Link to post
Share on other sites
On 1/7/2020 at 2:56 PM, HorcikDesigns said:

Would it be possible to make the app work even with locked touchscreen? I would like to have phone locked and placed in pocket. 

Unfortunately it's not possible since when the phone is unlocked it doesn't get the controller events.

21 hours ago, iuliand said:

Two of my suggestions for the app:

1) Make the play screen "dark mode" (use black background instead of white) in order to preserve battery for those having OLED displays. Or even better enable a dark theme for the entire app.

2) For BuWizz 2, in the play screen, make the Ludicrous mode optional. That is, in the  Buwizz 2 device settings add a toggle button for the Ludicrous mode button to be displayed or not in the play screen. That's because some 9V devices connected to BuWizz may not support the 12V delivered by the Ludicrous mode, like an IR receiver supplied from the BuWizz port, and I would like not to accidentally enable it from the play screen.

1. Good idea, if I have time I'll modify it to dark.
2. Hmm, interesting. I put it on my TODO list.

2 hours ago, OlSom said:

I still experience the same issue with the servo getting stuck with 2.5 on Android. Interestingly, it also seems to effect SBrick. Going back to 2.3 seemed to have solved that, I haven't been able to get either the SBrick of the PU stuck since I downgraded. 

Another issue I see while using the new L motor as a servo is that it's output is really "choppy", on both 2.3 and 2.5. I don't really see this when controlling from the Control+ app. 

Yes, I'm also experiencing lags and halts, so I'm on it...

Share this post


Link to post
Share on other sites
 
 
 
1
13 hours ago, imurvai said:

Unfortunately it's not possible since when the phone is unlocked it doesn't get the controller events.

There might be a workaround to this. If in the play screen there is a button to "lock the screen" that puts the app in full screen (or whatever it is called, just like games do) with a black screen (or minimal info displayed) and a giant slider to "unlock". It is unlikely that the slider will be dragged up to the end in the pocket. The slider is one idea, but any other unique "unlock" sequence will work. The only drawback is that some phones have buttons that can't be inhibited in the "lock/pocket" mode. With some careful usage, this may work. I'm not convinced this is feasible, it's just a quick idea that just came to my mind.

Share this post


Link to post
Share on other sites

Hi @imurvai

What a great app you made,
I stumbled into it when searching for a way to control my R9800 with something else but a phone.

I do however a question
I connected both hubs and named them lower and upper
Then I made a profile named lower to control the lower hub and I can now drive the machine around and rotate it with a gamecontroller
WOW that was real easy

Then I tried to make a profile to control all upper things
So I made a second profile ment to control the upper hub but here I get stuck
How can I tell this second profile that it must use the upper hub?
I can find a way to change, it automatically assumes that I want to use "lower"

Share this post


Link to post
Share on other sites
18 minutes ago, JaBaCaDaBra said:

Hi @imurvai

What a great app you made,
I stumbled into it when searching for a way to control my R9800 with something else but a phone.

I do however a question
I connected both hubs and named them lower and upper
Then I made a profile named lower to control the lower hub and I can now drive the machine around and rotate it with a gamecontroller
WOW that was real easy

Then I tried to make a profile to control all upper things
So I made a second profile ment to control the upper hub but here I get stuck
How can I tell this second profile that it must use the upper hub?
I can find a way to change, it automatically assumes that I want to use "lower"

You can click the name of the device to get a list of connected devices:

image.png.261f01704239cd6e5de5dcbd00be0230.png

Share this post


Link to post
Share on other sites
19 hours ago, JaBaCaDaBra said:

Ow that was to easy :-)
I overlooked it

You can also rename the hubs in the device details page for easier identification.

Share this post


Link to post
Share on other sites

Version 2.6 has been released for both Android and iOS. Changes:

- Introduced the initial version of the sequences feature for basic automation like flashing lights
- Minor fixes

Happy playing!

Share this post


Link to post
Share on other sites

Would it be possible to add support for more than one controller?

If one is added then it just behaves like now.

If it detects a second one then it let’s you assign buttons for every controller.

With this it would be possible to control more than one Moc with just one mobile.

Share this post


Link to post
Share on other sites

With 2.6 on android, I still got problem with sluggish servo. Revert back to version 2.3 that works perfect on android 😢

Edited by azimsu80

Share this post


Link to post
Share on other sites

Which kind of controller can I use? Since I plan to change from Android to iOS it has to be one, which works with both systems.

Share this post


Link to post
Share on other sites
9 hours ago, tismabrick said:

Would it be possible to add support for more than one controller?

Yes, it's on my TODO list.

4 hours ago, azimsu80 said:

With 2.6 on android, I still got problem with sluggish servo. Revert back to version 2.3 that works perfect on android 😢

Yes, it's a known issue on certain Android phones and unfortunately I haven't found out why it's happening :(

4 minutes ago, myvideo000 said:

Which kind of controller can I use? Since I plan to change from Android to iOS it has to be one, which works with both systems.

From iOS 13 the Sony PS4 and XBox One controllers are supported so that they can be used on both platforms.

Share this post


Link to post
Share on other sites
2 hours ago, imurvai said:

From iOS 13 the Sony PS4 and XBox One controllers are supported so that they can be used on both platforms.

Thanks for the answer. What about third party controllers? Is it enough if they support or are supported by PS4 and / or XBox One?

Share this post


Link to post
Share on other sites
Just now, myvideo000 said:

third party controllers

I use a L.Y.N.X. Controller from Madcatz, works flawless.

Share this post


Link to post
Share on other sites

Hi,

I tried your app over the weekend with a Buwizz dumptruck and a simple offroader and it works realy great!

But here are two things that would be great for powered up:

- Freely adjustable servo angle. Would be great for steering with actuators (like modded 42030) if the steering goes back to center automatically.

- Some kind of calibration/limits for normal motor movement, like the 42100 has, so you don't run into built in limitations. Maybe manual if automatic calibration is too complicated.(go to position 1 -> ok -> go to position 2 -> ok --> movement between these two angles is allowed)

Thank you :).

Share this post


Link to post
Share on other sites

Hi @imurvai
This week i bought a Buwizz and found that posts 1 and 2 are swapped and post 3 and 4 too when I setup a test profile
What am I doing wrong?

The Ports are connected conform the picture in the app

edit
In device test it does not the same but only on ports 1 and 2
slider 1 goes to port 2
slider 2 goes to port 1
slider 3 goes to port 3
slider 4 goes to port 4

That even more strange,
In profile all ports are swapped
In test only 1 and 2

Edit 2
Tested also on a Sbrick and there the port mapping is 100% correct

Edited by JaBaCaDaBra

Share this post


Link to post
Share on other sites
1 hour ago, Gimmick said:

Hi,

I tried your app over the weekend with a Buwizz dumptruck and a simple offroader and it works realy great!

But here are two things that would be great for powered up:

- Freely adjustable servo angle. Would be great for steering with actuators (like modded 42030) if the steering goes back to center automatically.

- Some kind of calibration/limits for normal motor movement, like the 42100 has, so you don't run into built in limitations. Maybe manual if automatic calibration is too complicated.(go to position 1 -> ok -> go to position 2 -> ok --> movement between these two angles is allowed)

Thank you :).

Hi, the actuator calibration would only be possible with the new PoweredUp motors like in the 42100 set as only these motors have encoders built in. At the moment I don't see when I have capacity to implement this feature.

48 minutes ago, JaBaCaDaBra said:

Hi @imurvai
This week i bought a Buwizz and found that posts 1 and 2 are swapped and post 3 and 4 too when I setup a test profile
What am I doing wrong?

You did nothing wrong, unfortunately it's a known issue for certain BuWizz2 devices. I don't know exactly how to detect if the ports are swapped so most probably I'll add an option to tell if the ports need to be swapped.

Share this post


Link to post
Share on other sites
10 hours ago, imurvai said:

Hi, the actuator calibration would only be possible with the new PoweredUp motors like in the 42100 set as only these motors have encoders built in. At the moment I don't see when I have capacity to implement this feature.

 

Np :). Wouldn't it maybe a simple solution to increase the maximum servo angle from 180° to the maximum possible value, the motors support? So for actuator- or super slow offroad-steering you just set the angle to 7200° for example.

Share this post


Link to post
Share on other sites
2 hours ago, Gimmick said:

Np :). Wouldn't it maybe a simple solution to increase the maximum servo angle from 180° to the maximum possible value, the motors support? So for actuator- or super slow offroad-steering you just set the angle to 7200° for example.

Sure, I'll check if the servo range can be extended...

Share this post


Link to post
Share on other sites
3 hours ago, Gimmick said:

the angle to 7200° for example.

FYI the needed range for Liebherr long actuators is about 26000°

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.