Jump to content


Problems embedding youtube videos


9 replies to this topic

#1 mostlytechnic

mostlytechnic

  • Wiener Envy


    Posts: 978
    Joined: 20-August 10
    Member: 12726
    Country: USA

Posted 09 November 2012 - 03:29 AM

I've got some youtube videos for my reviews. I include them by just pasting the youtube.com/whatever URL, and the board makes them into embedded videos. However, if you edit the post later, the video links are lost. The entire media tags and URL disappear. Any idea why?

Mostlytechnic's Bazaar post | Mostlytechnic's Bricklink store



Now playing as Storm in speedy's Cosplay Mafia

Died in the conclusion, losing because he's an idiot as Monty Thornton, the cook aboard the USS Portland in jamesn's Red Mafia

Survived and won as Brice Marden in Hinck and Trumpet's Minimal Mafia

Survived to the conclusion as a winning Council musician / decorator Melanie Detruccio in TrumpetKing's CMF Mafia

Poisoned (and lost) as townie Molly Tennant, saloon dancer in Tamamono's Silver City Mafia

Won (but night-killed near the end) as the townie The Talking Animal in Zepher's Mafia Mafia

Survived till the end (but still lost) as townie Mary Jane the Jock in Aperture Academy


#2 Darkdragon

Darkdragon

  • Destroyed Dreams of Super-Santa


    Posts: 5109
    Joined: 22-November 10
    Member: 14331
    Country: USA

Posted 09 November 2012 - 03:52 AM

I haven't had this issue with any of the posts I have edited.  Can you give a link to a post you are having this problem with?

#3 mostlytechnic

mostlytechnic

  • Wiener Envy


    Posts: 978
    Joined: 20-August 10
    Member: 12726
    Country: USA

Posted 09 November 2012 - 04:34 AM

http://www.eurobrick...showtopic=75864

If I edit the post and save, the 3 videos near the end disappear. I have to re-paste the URLs and have it re-embed them if I edit anything in the post, like fixing a typo. It did this while I was working on the review over several days in the RA as well.

Mostlytechnic's Bazaar post | Mostlytechnic's Bricklink store



Now playing as Storm in speedy's Cosplay Mafia

Died in the conclusion, losing because he's an idiot as Monty Thornton, the cook aboard the USS Portland in jamesn's Red Mafia

Survived and won as Brice Marden in Hinck and Trumpet's Minimal Mafia

Survived to the conclusion as a winning Council musician / decorator Melanie Detruccio in TrumpetKing's CMF Mafia

Poisoned (and lost) as townie Molly Tennant, saloon dancer in Tamamono's Silver City Mafia

Won (but night-killed near the end) as the townie The Talking Animal in Zepher's Mafia Mafia

Survived till the end (but still lost) as townie Mary Jane the Jock in Aperture Academy


#4 Big Cam

Big Cam

  • A good mood, too.


    Posts: 13999
    Joined: 02-April 09
    Member: 5701
    Country: USA

Posted 09 November 2012 - 02:43 PM

I went to your post and I added a : after the words The conclusion right by the videos and I saved it and the videos are still embedded.

I did notice that when I edited it, I didn't see the media tags around the URLs, yet they still show as embedded, I'd assume this is due to the new software.

Test





Yup, you don't need the media tags, I had copied your videos in case I screwed up your post. I just pasted the URL here.

#5 mostlytechnic

mostlytechnic

  • Wiener Envy


    Posts: 978
    Joined: 20-August 10
    Member: 12726
    Country: USA

Posted 09 November 2012 - 05:30 PM

I didn't add media tags - I just pasted the youtube links in, and the forum software added them when I saved the post.

Just tried - when I hit edit on the post, it came up in the editor with NOTHING in the video section. there's just a couple blank lines between the paragraph introducing the videos and the line saying they're in 1080p on youtube. Hit cancel and it was fine. But editing makes them disappear.

Tried some other things. If I hit quote on the post, it quotes it into a new post, but the videos are completely gone. Then I went to my post of the same review in the RA Teacher's section - if I edit or quote there, ONE video link remains (in media tags) but the other two videos are gone. Very weird - maybe just something with my account or something?

(testing using a different video link)

edit: ok, tried several different videos (mine and other peoples) and repeated editing and saving of this post, and it's working fine here. Wonder if just something weird is going on with my computer/that post. Dunno....

Mostlytechnic's Bazaar post | Mostlytechnic's Bricklink store



Now playing as Storm in speedy's Cosplay Mafia

Died in the conclusion, losing because he's an idiot as Monty Thornton, the cook aboard the USS Portland in jamesn's Red Mafia

Survived and won as Brice Marden in Hinck and Trumpet's Minimal Mafia

Survived to the conclusion as a winning Council musician / decorator Melanie Detruccio in TrumpetKing's CMF Mafia

Poisoned (and lost) as townie Molly Tennant, saloon dancer in Tamamono's Silver City Mafia

Won (but night-killed near the end) as the townie The Talking Animal in Zepher's Mafia Mafia

Survived till the end (but still lost) as townie Mary Jane the Jock in Aperture Academy


#6 Darkdragon

Darkdragon

  • Destroyed Dreams of Super-Santa


    Posts: 5109
    Joined: 22-November 10
    Member: 14331
    Country: USA

Posted 09 November 2012 - 05:41 PM

The problem appears to be with the IPB quick edit mode. The post you linked to has a lot of BBCode and text, too much for the quick edit to handle correctly.  There really isn't much can be done about it at this point.

When you have a long post like that, you may have to manually fix the bottom portion before saving any changes.

#7 mostlytechnic

mostlytechnic

  • Wiener Envy


    Posts: 978
    Joined: 20-August 10
    Member: 12726
    Country: USA

Posted 09 November 2012 - 06:45 PM

thanks for the info - is there any way to edit a post straight into the full editor rather than having to go through the quick edit first? Wonder if that would work better for big posts.

Mostlytechnic's Bazaar post | Mostlytechnic's Bricklink store



Now playing as Storm in speedy's Cosplay Mafia

Died in the conclusion, losing because he's an idiot as Monty Thornton, the cook aboard the USS Portland in jamesn's Red Mafia

Survived and won as Brice Marden in Hinck and Trumpet's Minimal Mafia

Survived to the conclusion as a winning Council musician / decorator Melanie Detruccio in TrumpetKing's CMF Mafia

Poisoned (and lost) as townie Molly Tennant, saloon dancer in Tamamono's Silver City Mafia

Won (but night-killed near the end) as the townie The Talking Animal in Zepher's Mafia Mafia

Survived till the end (but still lost) as townie Mary Jane the Jock in Aperture Academy


#8 Darkdragon

Darkdragon

  • Destroyed Dreams of Super-Santa


    Posts: 5109
    Joined: 22-November 10
    Member: 14331
    Country: USA

Posted 09 November 2012 - 07:23 PM

View Postmostlytechnic, on 09 November 2012 - 06:45 PM, said:

thanks for the info - is there any way to edit a post straight into the full editor rather than having to go through the quick edit first? Wonder if that would work better for big posts.
Unfortuantely there is not. You could try turning off the RTE (just use any post to do that, not the big post though), and then go into edit the big post and click the "Use Full Editor" button.  In this manor, the quick edit won't be trying to parse the BBCode and so it might not lose your original data.  It's a theory, and I haven't tried this myself, but let me know if you do and what your results are.

#9 mostlytechnic

mostlytechnic

  • Wiener Envy


    Posts: 978
    Joined: 20-August 10
    Member: 12726
    Country: USA

Posted 09 November 2012 - 07:56 PM

Tried that, and it appears to work. Edited one of my posts here to turn off the fancy editor, then tried the quick edit on the RA forum version of the review, and all 3 video links were there. If I toggled that back to the fancy mode, they vanished. Guess they must be going over some limit in the forum software. I'll just keep that in mind for the future! most people will never have a problem - just us big, long review writers :) It is weird though that the bbcode after the videos stays just fine (the bolded text in the conclusion, etc) - but the videos WERE the last thing I added to the review. I had the whole thing written, added those, then saved it in the RA. When I copy and pasted it over to the Technic forum, the videos vanished and I had to re-add them, so maybe the C&P of embedded media doesn't work, so they were still the last code added to the post, so they're what gets lost?

Mostlytechnic's Bazaar post | Mostlytechnic's Bricklink store



Now playing as Storm in speedy's Cosplay Mafia

Died in the conclusion, losing because he's an idiot as Monty Thornton, the cook aboard the USS Portland in jamesn's Red Mafia

Survived and won as Brice Marden in Hinck and Trumpet's Minimal Mafia

Survived to the conclusion as a winning Council musician / decorator Melanie Detruccio in TrumpetKing's CMF Mafia

Poisoned (and lost) as townie Molly Tennant, saloon dancer in Tamamono's Silver City Mafia

Won (but night-killed near the end) as the townie The Talking Animal in Zepher's Mafia Mafia

Survived till the end (but still lost) as townie Mary Jane the Jock in Aperture Academy


#10 Big Cam

Big Cam

  • A good mood, too.


    Posts: 13999
    Joined: 02-April 09
    Member: 5701
    Country: USA

Posted 09 November 2012 - 10:25 PM

Maybe the board remembers what you do and ditches the last thing. Very weird.

Also darkdragons explanation makes sense. I'm on my phone so the RTE is off by default.



Reply to this topic



  


0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users