Jump to content


LDD 4.3.5 bugs

LDD bugs 4.3.5

  • This topic is locked This topic is locked
167 replies to this topic

#1 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 18 September 2012 - 02:03 PM

Report all 4.3.5 bugs here

View PostBanjo, on 18 September 2012 - 01:49 PM, said:

Hi all! I'm new to this place and somewhat new to LDD... but am I the only one finding that part 87781 (space helmet, as seen in Alien Conquest and on the Intergalactic Girl minifig) suddenly no longer allows visors (part 2447) to be attached? It worked with the previous version of LDD (4.2.5) but not the new one I just downloaded (4.3.5).

If I'm not alone... is there a way to submit this to the right folks as a bug report? It's very frustrating to have every other space model I open auto-delete the visors off the minifig helments!
You're right.

Workaround: Place the visor on a 3842 helmet. Rotate the visor about 7 degrees forward (flip it down). Now it will fit on the 87781.

EDIT: You can report in this forum (here is the new topic for 4.3.5). I collect each and everyone and send to the LDD Team. You can also report a bug to the LEGO Customer Service help desk.

#2 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 18 September 2012 - 03:07 PM

I got some extra info back quickly about the previous bug. Apparently a fix was made for the visor so that it would fit on the new SW helmet 61182. Unfortunately the visor was then not fully regression tested. But the bug report has been acknowledged, and I guess that's a good first step.

While playing around I also noticed that the visor 6119 will also not fit on some of the space helmets (like 87781), but that seems to be more a collision error bug. Also reported now.

Anyway, if you guys find any other bugs relating to helmets and visor (or anything else), post 'em here. And since this is a new topic for the 4.3.5 release - if you find any errors that was allready in 4.2.5 and didnt' get fixed, please repost them here again (or link to the post in the 4.2.5 bug topic)

#3 pbk420

pbk420

    Posts: 83
    Joined: 08-August 10
    Member: 12460

Posted 18 September 2012 - 05:23 PM

Certain aspects of paint arent working like it used to. Used to be able to group lots of parts and paint them all one color at once but i cant seem to get it to work now. More bugs to follow.

#4 Flobnomdob

Flobnomdob

    Posts: 217
    Joined: 03-September 11
    Member: 20208
    Country: Wales

Posted 18 September 2012 - 05:35 PM

I've found a bug- part (MINI ARMOUR WITH ARMS) will not connect to the top of a minifg torso, only onto the legs. I don't know if the actual part can do this.
My flickr-
Posted Image
Minotaurs rule...

Quote

All hail Flobnomdob!

#5 ADHO15

ADHO15

  • Another day, another hat


    Posts: 3820
    Joined: 07-January 08
    Member: 2428
    Country: NZ

Posted 18 September 2012 - 05:38 PM

View Postpbk420, on 18 September 2012 - 05:23 PM, said:

Certain aspects of paint arent working like it used to. Used to be able to group lots of parts and paint them all one color at once but i cant seem to get it to work now. More bugs to follow.
Yes, I've found that quite annoying.

There are also a pair of non-functioning studs in the centre of part 4855, I found. I'm pretty sure they weren't like that before the update.
Brickshelf 1 (adho15) - reviews, photos, MS Paint characters
Brickshelf 2 (adho16) - contest entries, Clone Conflict, LDD

#6 kamos

kamos

    Posts: 31
    Joined: 18-August 11
    Member: 19856
    Country: Slovakia

Posted 18 September 2012 - 05:43 PM

edit: ADHO15 was faster but...
Unable to add anything into 4855 Roof tile (as shown on the picture), everywhere else works fine. It was possible in previous version.
Posted Image

Edited by kamos, 18 September 2012 - 05:45 PM.


#7 pbk420

pbk420

    Posts: 83
    Joined: 08-August 10
    Member: 12460

Posted 18 September 2012 - 06:24 PM

Part # 93556 the monster hairpiece the forehead section wont let me paint it certain colors like (151)-sand green,(28)-dark green ,(1)-white ,and others but some colors seem to work ok .

#8 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 18 September 2012 - 06:27 PM

View Postpbk420, on 18 September 2012 - 05:23 PM, said:

Certain aspects of paint arent working like it used to. Used to be able to group lots of parts and paint them all one color at once but i cant seem to get it to work now. More bugs to follow.
After you select the bricks and switch to the Pain tool, you have to actively click the color in the color palette to make it work.

#9 Tontus

Tontus

    Posts: 97
    Joined: 15-September 11
    Member: 20444

Posted 18 September 2012 - 06:27 PM

When you put a torso on the snake body, it doesn't fit all the way. You can slide it all the way down using the group move trick, so not that big of a deal.

Edited by Tontus, 18 September 2012 - 06:28 PM.


#10 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 18 September 2012 - 06:37 PM

View PostFlobnomdob, on 18 September 2012 - 05:35 PM, said:

I've found a bug- part (MINI ARMOUR WITH ARMS) will not connect to the top of a minifg torso, only onto the legs. I don't know if the actual part can do this.
Looking at BL, it should connect to the top of a torso, so that's a bug. Like you say, in LDD it only connects to the legs...but I'm wondering if that should even be possible with the physical brick. Anyone who has one that can test?

EDIT: the brick we're talking about is the top of one of the Ninjago figs: 99415 in LDD, this in BL

#11 pbk420

pbk420

    Posts: 83
    Joined: 08-August 10
    Member: 12460

Posted 18 September 2012 - 06:45 PM

part # 92759 Watto Head is also not letting you paint certain areas

#12 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 18 September 2012 - 06:46 PM

View PostTontus, on 18 September 2012 - 06:27 PM, said:

When you put a torso on the snake body, it doesn't fit all the way. You can slide it all the way down using the group move trick, so not that big of a deal.
It seems you can also fit it by just dragging the torso down towards the legs. At some very fine point it will "click on" all the way.

(odd bug).

#13 vynsane

vynsane

    Posts: 472
    Joined: 21-May 10
    Member: 10811

Posted 18 September 2012 - 07:55 PM

Sounds similar to how minifig heads behaved with the torso neck stem before they shortened the design of the stem.

Edited by vynsane, 18 September 2012 - 07:55 PM.

ALL HAIL THE BLACTRON EMPIRE!

Flickr Photostream | Dropbox - LDD files and instruction archive

The SVG Decals Library - Discuss on EB | Contribute on GitHub

#14 Aanchir

Aanchir

  • Color Encyclopedia


    Posts: 9061
    Joined: 31-December 09
    Member: 8841
    Country: United States

Posted 18 September 2012 - 08:35 PM

View PostSuperkalle, on 18 September 2012 - 06:27 PM, said:

After you select the bricks and switch to the Pain tool, you have to actively click the color in the color palette to make it work.
Wow, I greatly appreciate this feature! It's always annoyed me how I have to make sure I have the right color with the paint tool before I group select objects to color. Now I can select them and worry about the color after-the-fact.

View PostSuperkalle, on 18 September 2012 - 06:37 PM, said:

Looking at BL, it should connect to the top of a torso, so that's a bug. Like you say, in LDD it only connects to the legs...but I'm wondering if that should even be possible with the physical brick. Anyone who has one that can test?

EDIT: the brick we're talking about is the top of one of the Ninjago figs: 99415 in LDD, this in BL
It is not possible with the actual piece as far as I know. I'm pretty sure there is only one anti-stud on the underside. But I will have to check-- if it is possible, it's a really pleasant surprise. So don't send a bug report just yet.

#15 SpiderSpaceman

SpiderSpaceman

  • Got Balls?


    Posts: 1164
    Joined: 17-July 09
    Member: 6727
    Country: USA

Posted 19 September 2012 - 04:28 AM

the pterodactyl 98653 has no attachment point for the lower beak 98087.
the garmadon umpire topper 99415 has no attachment point to a minifig neck.

#16 hrontos

hrontos

    Posts: 727
    Joined: 05-August 11
    Member: 19500
    Country: Slovakia

Posted 19 September 2012 - 07:55 AM

There are 3 parts having wrongly stored name in the new brickset.

Part ID 87799 has name "HEART" WITH 3.18 SHAFT, part ID 85969 has name RIM CASE Ø36.7 "CALLARDO" and part ID 43751 has name MINI WIG MAN "NO. 2".

Problem is with the double quotes. According to XML standard double quotes has to be stored as " and not directly as ".

So instead of designname="MINI WIG MAN "NO. 2"" it should be there designname="MINI WIG MAN "NO. 2"".

LDD cannot load these parts and ignores them.

In previous brickset version these parts were named properly and could be used in LDD without problems.

#17 Banjo

Banjo

  • Not a Sock Puppet


    Posts: 69
    Joined: 13-March 12
    Member: 27291

Posted 19 September 2012 - 08:08 AM

View PostSuperkalle, on 18 September 2012 - 03:07 PM, said:

I got some extra info back quickly about the previous bug. Apparently a fix was made for the visor so that it would fit on the new SW helmet 61182. Unfortunately the visor was then not fully regression tested. But the bug report has been acknowledged, and I guess that's a good first step.

While playing around I also noticed that the visor 6119 will also not fit on some of the space helmets (like 87781), but that seems to be more a collision error bug. Also reported now.

Anyway, if you guys find any other bugs relating to helmets and visor (or anything else), post 'em here. And since this is a new topic for the 4.3.5 release - if you find any errors that was allready in 4.2.5 and didnt' get fixed, please repost them here again (or link to the post in the XXXXX)

Cool! Thanks for that... so I don't need to report it to Lego now? They're "on the case", hopefully? Fingers crossed for a little patch soon, cos it's driving me nuts! :(

EDIT: Literally a minute after I posed this, I opened LDD and got a "0.00mb" update... that seems to have FIXED this! Woohoo! Talk about awesome!!! :D

One other thing I just noticed... not sure if it's a bug or a "feature" (program limitation), but I seem to be able to get only one "neck accessory" to attach to a minifig. Say, if you want to attach both 95201 and 2526 on the same figure... no go! :(

Edited by Banjo, 19 September 2012 - 08:16 AM.


#18 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 19 September 2012 - 11:55 AM

View PostBanjo, on 19 September 2012 - 08:08 AM, said:

Cool! Thanks for that... so I don't need to report it to Lego now? They're "on the case", hopefully? Fingers crossed for a little patch soon, cos it's driving me nuts! :(

EDIT: Literally a minute after I posed this, I opened LDD and got a "0.00mb" update... that seems to have FIXED this! Woohoo! Talk about awesome!!! :D

One other thing I just noticed... not sure if it's a bug or a "feature" (program limitation), but I seem to be able to get only one "neck accessory" to attach to a minifig. Say, if you want to attach both 95201 and 2526 on the same figure... no go! :(
Yes, and it was you that found it  :classic:  I sent in a report, and the day after it was fixed. I think that's pretty cool also.

about the minifig thing: only one neck item at a time allowed at the moment. This is not so strange actually, because if I remember correctly it is very rarely that official sets/minifigs have dual accessories (meaning that it may be that the minifig was not designed/made for it). But I'm not deep water here, so I'm not 100% usre. But there is a workaround using the "group and move" method. It's been explained many times in the forum. See if you can find it. Otherwise ask again here and maybe someone can help.

#19 Banjo

Banjo

  • Not a Sock Puppet


    Posts: 69
    Joined: 13-March 12
    Member: 27291

Posted 19 September 2012 - 02:28 PM

View PostSuperkalle, on 19 September 2012 - 11:55 AM, said:

Yes, and it was you that found it  :classic:  I sent in a report, and the day after it was fixed. I think that's pretty cool also.

about the minifig thing: only one neck item at a time allowed at the moment. This is not so strange actually, because if I remember correctly it is very rarely that official sets/minifigs have dual accessories (meaning that it may be that the minifig was not designed/made for it). But I'm not deep water here, so I'm not 100% usre. But there is a workaround using the "group and move" method. It's been explained many times in the forum. See if you can find it. Otherwise ask again here and maybe someone can help.

Thanks heaps for that! Such an annoying bug, squashed so quickly!

I was mostly curious about the multiple "neck accessories" for things like mask/beard and cape combos... set 9469 has a beard+cape mix like this (Gandalf), for example, while set 7065 has THREE neck accessories on one awesome minifig (alien 'mask'+epaulettes+cape)! :D

Will try and find the 'workaround' you mentioned here in the meantime!

#20 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 19 September 2012 - 03:12 PM

As you have noticed, the brickset is now on version 385.2
I was told that two bugs are fixed:
1) the "VISOR/HELMET" bug
2) the "4855 Roof tile" where bricks wouldn't fit.

(The latter one was the most serious since it would cause bricks to be removed while opening and old LXF).

#21 Scorpion

Scorpion

    Posts: 177
    Joined: 22-August 09
    Member: 7128

Posted 19 September 2012 - 04:10 PM

Goddamn it! They added the old technic turntable (74643), but it's bugged!! I can't get it to mesh with a 24 teeth gear (3648)!

I used it to replace a placeholder new style technic turntable with 56 teeth, but when I try to replace it with the proper part, it doesn't fit! I've tried rotating the gear, the turntable, but no dice. And the worst part is that I know that construction is legitimate, I've done it in Real Life™!

Could you report this to the LDD team, SuperKalle? Also, the 24 teeth crown gear is still wonky...

#22 Superkalle

Superkalle

    Posts: 6082
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 19 September 2012 - 06:45 PM

View PostScorpion, on 19 September 2012 - 04:10 PM, said:

Goddamn it! They added the old technic turntable (74643), but it's bugged!! I can't get it to mesh with a 24 teeth gear (3648)!

I used it to replace a placeholder new style technic turntable with 56 teeth, but when I try to replace it with the proper part, it doesn't fit! I've tried rotating the gear, the turntable, but no dice. And the worst part is that I know that construction is legitimate, I've done it in Real Life™!

Could you report this to the LDD team, SuperKalle? Also, the 24 teeth crown gear is still wonky...
Yeah, you're right - the teeth won't mes. Bummer. It looks very much like some collision volumes in the brick that are too big. I'm rating this high prio since it makes the brick pretty much impossible to use.

#23 Scorpion

Scorpion

    Posts: 177
    Joined: 22-August 09
    Member: 7128

Posted 19 September 2012 - 07:21 PM

View PostSuperkalle, on 19 September 2012 - 06:45 PM, said:

Yeah, you're right - the teeth won't mes. Bummer. It looks very much like some collision volumes in the brick that are too big. I'm rating this high prio since it makes the brick pretty much impossible to use.

Exponential arigatos, Superkalle!!!

#24 marco9999

marco9999

    Posts: 289
    Joined: 29-September 10
    Member: 13516
    Country: Italy

Posted 19 September 2012 - 09:31 PM

Some bugs from the previous versions and still in 4.3:

- airtanks 3838 do not allow connection of 30214 insectoid helmet to minifig's head due to some collision error. Such assembly takes place in almost all set from Space/Insectoids theme.

- it is still not possible to place two or more neck accessories on one minifig, for example 2526 epaulette and 2524 knapsack in Pirates sets.

- railway element 85976 cannot be connected from beneath; all other railway elements can, but they all miss below studs, at least they are not graphically visible. They look perfectly flat.

#25 iceleftd

iceleftd

    Posts: 80
    Joined: 23-January 12
    Member: 24772
    Country: US

Posted 19 September 2012 - 11:46 PM

I posted the following bug back in January but it's still there.

Posted Image

I've used false colors for some pins to make the issue easier to describe. The blue beam fits quite nicely centered on the green pins or the red pins, but not both the green and red pins. This works in real life, of course.

I'm guessing the NXT brick geometry is at fault.  If you lay the blue beam on the green pins you can see a slight gap between the base of the beam and the underside of the NXT.





Also tagged with one or more of these keywords: LDD, bugs, 4.3.5

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users