Jump to content


Unlock all bricks in LDD with Extended Mode - instructions here


  • Please log in to reply
17 replies to this topic

#1 Superkalle

Superkalle

    Posts: 5634
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 03 April 2011 - 11:41 PM

UPDATE January 2012

There is no longer any need to manually unlock the Extended Mode - it is available to all users when simply installing LDD



Unlock all the bricks in LDD with LDD Extended Mode
(This information by kind permission of the LDD Development Team in Billund)


With the release of LDD 4.1 comes a new mode - LDD Extended - that you need to manually activate.

So what about the "old" Lego Universe mode? Well, it is now activated for all users out-of the-box - no need to edit the preferences.ini file to see it. However (and this is important), the new Universe mode does not have all the bricks we are used to. Luckily, the LDD Team in Billund (thanks guys!) have thought about us more hardcore LDD fans and has given us LDD Extended mode which again unlocks all bricks.  

Also, please be aware that LEGO is making LDD Extended mode available to us LDD fans as-is. LEGO takes no responsibility for this mode and there is no support available.

How to unlock LDD Extended mode
Please do NOT re-post this information on the internet. Instead, link to this post. Thank you.

For windows users
1.  Close down LDD
2.  Find the file preferences.ini the LEGO Digital Designer folder.

For Windows 7 and Vista it can be found here C:\Users\UserName\AppData\Roaming\LEGO Company\LEGO Digital Designer\preferences.ini
For Windows XP here: C:\Documents And Settings\UserName\ApplicationData\Lego Company\Lego Digital Designer\preferences.ini
NOTE: If you can't find this folder, the read here how to make it visible OR simply enter %appdata% into the Explorer address bar (or Start menu search box) which will automagically open the right place (thanks Andy for the tip)


3.  Open preferences.ini in a text editor and add the line: ThemeAccess=LDDExtended
4.  Save the file
5.  Restart LDD and now you have access to LDD Extended Mode

For mac users.
1.  Close down LDD
2.  Find the file preferences.ini in /User/Library/Application Support/LEGO Company/LEGO Digital Designer/preferences.ini

3.  Open it in a text editor and add the line: ThemeAccess=LDDExtended  
4.  Save the file
5.  Restart LDD and now you have access to a LEGO Universe palette

Regarding LION on the Mac (thanks to Vynsane for the info)
With this newest release of the Macintosh Operating System, the "Library" folder in each individual "User" folder is hidden by default. You will first need to unhide it in order to access the directory structure "{hard drive name}/Users/{user name}/Library/Application Support/LEGO Company/LEGO Digital Designer/preferences.ini"

Open Terminal (via the 'Go' menu when in Finder and selecting 'Utilities', then double-clicking 'Terminal') and type the following (replace {user name} with your actual user name):

chflags nohidden /users/{user name}/library

This will unhide that directory, allowing you access to the folders therein, including the files necessary to activate 'Extended Mode' per above.



Want to discuss Extended Mode?
Go HERE to discuss Extended Mode, questions, issues, problems etc.



================

Extended Mode Q & A
Q: If I activate LDD Extended mode, will LDD still automatically update over the internet when a new version is released?
A: Yes

Q: If I design in LDD Extended mode, will the model also open with LDD on computers that do not have this mode activated?
A: Yes

Q: Does Lego offer any end-user support on Extended mode?
A: No

Q: Are all colors available in LDD Extended mode?
A: Well most of them. Unlike for the other modes, there is a Legacy section with a selection of discontinued colors.
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings

#2 Superkalle

Superkalle

    Posts: 5634
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 04 April 2011 - 03:23 PM

STOP

Do not post in this topic

Instead please discuss the Extended Mode here

And please discuss the new LDD 4.1 release in general here

And report brick bugs here

Thanks!
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings

#3 vynsane

vynsane

    Posts: 472
    Joined: 21-May 10
    Member: 10811

Posted 12 August 2011 - 03:07 PM

I know it says not to post here, but this isn't a bug, discussion of LDD 4.1 or of discussion of 'Extended Mode' - it's a new step in the procedure required to activate 'Extended Mode' in OSX 10.7 "Lion".

With this newest release of the Macintosh Operating System, the "Library" folder in each individual "User" folder is hidden by default. You will first need to unhide it in order to access the directory structure "{hard drive name}/Users/{user name}/Library/Application Support/LEGO Company/LEGO Digital Designer/preferences.ini"

Open Terminal (via the 'Go' menu when in Finder and selecting 'Utilities', then double-clicking 'Terminal') and type the following (replace {user name} with your actual user name):

chflags nohidden /users/{user name}/library

This will unhide that directory, allowing you access to the folders therein, including the files necessary to activate 'Extended Mode' per above.

Superkalle - feel free to include these steps in your original post and delete this one if deemed necessary.

Edited by vynsane, 12 August 2011 - 03:09 PM.

ALL HAIL THE BLACTRON EMPIRE!

Flickr Photostream | Dropbox - LDD files and instruction archive

The SVG Decals Library - Discuss on EB | Contribute on GitHub

#4 Superkalle

Superkalle

    Posts: 5634
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 12 August 2011 - 05:08 PM

View Postvynsane, on 12 August 2011 - 03:07 PM, said:

I know it says not to post here, but this isn't a bug, discussion of LDD 4.1 or of discussion of 'Extended Mode' - it's a new step in the procedure required to activate 'Extended Mode' in OSX 10.7 "Lion".
Excellent Vynsane, thanks for the headsup!
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings

#5 deleus

deleus

    Posts: 14
    Joined: 15-July 11
    Member: 19060
    Country: Italy

Posted 10 September 2011 - 08:01 AM

Thanks for this post..i tried to edit preferences.ini...but it always gives me "access denied"..maybe i do some mistakes...please let me know
thanks

#6 deleus

deleus

    Posts: 14
    Joined: 15-July 11
    Member: 19060
    Country: Italy

Posted 10 September 2011 - 01:31 PM

i've done it!!! :) thanks!!!

#7 legofan1208

legofan1208

    Posts: 1
    Joined: 17-September 11
    Member: 20492

Posted 18 September 2011 - 06:37 AM

I realy need your help. When I try to save the preferences, it says Accese Denified. Please respond.

#8 AndyC

AndyC

    Posts: 1238
    Joined: 23-June 09
    Member: 6485

Posted 18 September 2011 - 09:33 AM

View Postlegofan1208, on 18 September 2011 - 06:37 AM, said:

I realy need your help. When I try to save the preferences, it says Accese Denified. Please respond.
You are almost certainly editing the wrong preferences file. You should be editing the one within your user folder, not the one in the Program Files directory.
Posted Image

#9 hrontos

hrontos

    Posts: 723
    Joined: 05-August 11
    Member: 19500
    Country: Slovakia

Posted 18 September 2011 - 10:38 AM

View PostAndyC, on 18 September 2011 - 09:33 AM, said:

You are almost certainly editing the wrong preferences file. You should be editing the one within your user folder, not the one in the Program Files directory.


Easiet way to get to right folder is to type %appdata% in windows explorer addres bar. Look for the LEGO Company folder there. Or type %appdata%\LEGO Company\LEGO Digital Designer.

#10 primitiv

primitiv

    Posts: 21
    Joined: 31-December 10
    Member: 15046
    Country: Belgium

Posted 06 November 2011 - 12:32 PM

View Postdeleus, on 10 September 2011 - 08:01 AM, said:

Thanks for this post..i tried to edit preferences.ini...but it always gives me "access denied"..maybe i do some mistakes...please let me know
thanks


This normally occurs when the file being edited is write-protected. The easiest solution to this is to save the file as "preferences.ini" and save it in a different location, for example on your desktop, and then simply copy this file into the LEGO directory.

Edited by primitiv, 06 November 2011 - 12:32 PM.


#11 deleus

deleus

    Posts: 14
    Joined: 15-July 11
    Member: 19060
    Country: Italy

Posted 07 November 2011 - 07:17 PM

View Postprimitiv, on 06 November 2011 - 12:32 PM, said:

This normally occurs when the file being edited is write-protected. The easiest solution to this is to save the file as "preferences.ini" and save it in a different location, for example on your desktop, and then simply copy this file into the LEGO directory.


thanks :)...i solved it a while back...ready to make some projects now..:)

#12 groomy1978

groomy1978

    Posts: 2
    Joined: 16-November 11
    Member: 21955

Posted 16 November 2011 - 09:36 PM

Hello everyone i'm new here. Was hoping that someone could help with LDD. I have just gone over to Mac for the first time and I am trying to get LDDExtended to work. I have followed the instructions above including the addition for LION but nothing seems to be working. The response that i get from adding the no hidden library is this:

usage: chflags [-fhv] [-R [-H | -L | -P]] flags file ...

I have no idea if this means that i has worked or not as I unfortunately haven't got a clue when it comes to computers.

Hope that somebody can help.

Tom

#13 vynsane

vynsane

    Posts: 472
    Joined: 21-May 10
    Member: 10811

Posted 16 November 2011 - 10:41 PM

Tom - you're replacing the text {user name} with your actual username, right? So if your login username for the Mac OS is Tom, you would use

chflags nohidden /users/Tom/Library

To check if it has worked, you would then open your OS hard drive (default name is 'Macintosh HD' on the desktop) and click 'Users' - > {user name folder} (in this case the theoretical 'Tom' folder, which should look like a house) and see if the folder 'Library' is visible.

If it is, you can the follow the rest of the directions as posted.

I tested this a bit and you may have hit 'return' after typing in the chflags command, before the 'nohidden...' part. Thats when I got the 'usage:' line: When I typed in JUST 'chflags' and hit 'return' - make sure you type it in on one line exactly as I posted above (replacing 'Tom' with your actual username).
ALL HAIL THE BLACTRON EMPIRE!

Flickr Photostream | Dropbox - LDD files and instruction archive

The SVG Decals Library - Discuss on EB | Contribute on GitHub

#14 groomy1978

groomy1978

    Posts: 2
    Joined: 16-November 11
    Member: 21955

Posted 16 November 2011 - 10:49 PM

View Postvynsane, on 16 November 2011 - 10:41 PM, said:

Tom - you're replacing the text {user name} with your actual username, right? So if your login username for the Mac OS is Tom, you would use

chflags nohidden /users/Tom/Library

To check if it has worked, you would then open your OS hard drive (default name is 'Macintosh HD' on the desktop) and click 'Users' - > {user name folder} (in this case the theoretical 'Tom' folder, which should look like a house) and see if the folder 'Library' is visible.

If it is, you can the follow the rest of the directions as posted.

I tested this a bit and you may have hit 'return' after typing in the chflags command, before the 'nohidden...' part. Thats when I got the 'usage:' line: When I typed in JUST 'chflags' and hit 'return' - make sure you type it in on one line exactly as I posted above (replacing 'Tom' with your actual username).


Thank you, yes i was replacing it with my user name (tom), but that wasn't working. I kept trying and for a some reason it worked, i can't see what i did different but at least its working now.

Many thanks

Tom

#15 vynsane

vynsane

    Posts: 472
    Joined: 21-May 10
    Member: 10811

Posted 17 November 2011 - 01:24 AM

Odd... Well, I'm glad it worked in the end.
ALL HAIL THE BLACTRON EMPIRE!

Flickr Photostream | Dropbox - LDD files and instruction archive

The SVG Decals Library - Discuss on EB | Contribute on GitHub

#16 MarqueIV

MarqueIV

    Posts: 1
    Joined: 19-November 11
    Member: 22085

Posted 19 November 2011 - 06:47 AM

Just a heads-up for Lion users... an even easier way to get to the library is to simply hold down the Opt/Alt key when the 'Go' menu is expanded.  When held down 'Library' will appear in the list... no Terminal needed!

#17 Dakar A

Dakar A

  • I've been outing Scum for OURS!


    Posts: 506
    Joined: 14-November 11
    Member: 21891
    Country: United States

Posted 25 November 2011 - 03:38 PM

Help!
I've done everything here, I am using windows, I edited the text under users, I also pressed enter and started a new line when I added extended mode. What am I doing wrong?

Posted Image  Posted Image Posted Image Posted Image

    

Top-notch Town Builder ! Played as Puss in Boots in Sandy's Mafia School: A Bed Time Story. Played as Ensign Jack Campbell , security in Bob's Excalibur Mafia. I My Flickr I Brick Town Talk! I Bricks in Space! I


#18 Superkalle

Superkalle

    Posts: 5634
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 25 November 2011 - 04:39 PM

View PostDakar A, on 25 November 2011 - 03:38 PM, said:

Help!
I've done everything here, I am using windows, I edited the text under users, I also pressed enter and started a new line when I added extended mode. What am I doing wrong?
Did you exit LDD first, edit the ini-file and then restart?

Most often when people have problems with activating Extended Mode, it's because they missed some part of the instruction.
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users