Jump to content


LDD doesn't work on my computer


  • Please log in to reply
6 replies to this topic

#1 Lorentzen

Lorentzen

  • Talented!


    Posts: 478
    Joined: 06-December 08
    Member: 4601
    Country: Denmark

Posted 04 June 2010 - 08:31 AM

Hi guys. I've made a screenshot of how LDD looks on my computer:
Posted Image

I use Windows 7, have a great graphic card and lots of memory and RAM, but it still does not work.

Do any of you guys have an idea of what to do?

Do I need to install something like a patch or a driver?

EDIT: I can't work on the program, because it keeps "reloading" everything and things are black, as if there's something wrong with the graphic settings

Edited by Lorentzen, 04 June 2010 - 08:37 AM.

Read my article on the classic LEGO Town House here
My Bricklink store: Blackbeard's Bricks
Including a 100% complete 6277 Imperial Trading Post - PLUS lots and lots of Pirate spare parts: Sails, hulls, masts, minifigs etc. etc.

#2 Calabar

Calabar

    Posts: 2234
    Joined: 11-April 10
    Member: 10232
    Country: Italy

Posted 04 June 2010 - 08:38 AM

Specify video card and version of driver you installed.
Explain how you installed the video card drivers.
Tell us if you have problems with this software only or with other OpenGL software/games too.

Already tried to uninstall the software, delete profile folder and reinstall it?

Edited by Calabar, 04 June 2010 - 08:39 AM.

"Official LEGO Sets made in LDD" topic: Read guidelines before posting!

#3 Lorentzen

Lorentzen

  • Talented!


    Posts: 478
    Joined: 06-December 08
    Member: 4601
    Country: Denmark

Posted 04 June 2010 - 09:00 AM

Hello.

I have tried to re-install LDD many times, with no effect.

I've never had any issues with other programs, so I don't know if OpenGL screws with my computer or this program.

This is my graphic card:
NVIDIA GeForce GTX 260 - latest driver. I guess I installed the video drivers regularly
Read my article on the classic LEGO Town House here
My Bricklink store: Blackbeard's Bricks
Including a 100% complete 6277 Imperial Trading Post - PLUS lots and lots of Pirate spare parts: Sails, hulls, masts, minifigs etc. etc.

#4 Superkalle

Superkalle

    Posts: 5633
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 04 June 2010 - 03:45 PM

This is most certainly a graphics card/refresh problem. I've had similar artifacts on my old laptop, but a modern card like the NVIDIA GeForce GTX 260 sholdn't have any problem. Like Calabar says, if shall be able to help you, you need to be very detailed here. Can you please report

OS (Win 7, but what version and 32 or 64 bit)
OS Language
Grapics Card manufacturer
Graphics Driver Version
DirectX version
LDD Version (3.1.3, right?)

Also, in LDD Edit > Preferences does it make any difference if you change compatability mode
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings

#5 jamzee

jamzee

    Posts: 158
    Joined: 05-August 08
    Member: 3664

Posted 09 August 2010 - 06:43 PM

Hi - I've had a similar problem, I've got an Advent 6551 laptop which (I think) has a UMA Intel GL40 graphics card.  It says

"Lego has caught an exception in the OpenGL display driver and will need to close" - then says about opening in compatability mode but completely freezes.  Oddly it worked ok on my old comp!

Any ideas would be very welcome!
Posted Image

#6 Superkalle

Superkalle

    Posts: 5633
    Joined: 21-December 08
    Member: 4755
    Country: Sweden

Posted 09 August 2010 - 07:23 PM

View Postjamzee, on 09 August 2010 - 06:43 PM, said:

Hi - I've had a similar problem, I've got an Advent 6551 laptop which (I think) has a UMA Intel GL40 graphics card.  It says

"Lego has caught an exception in the OpenGL display driver and will need to close" - then says about opening in compatability mode but completely freezes.  Oddly it worked ok on my old comp!

Any ideas would be very welcome!
Well, first one is defintely to update your video drivers, since it seems it is in the OpenGL drivers problem is.

Should be here you download: http://downloadcente... Chipset Family
Eurobricks Digital Design Forum - for all your LDD and Ldraw cravings

#7 jamzee

jamzee

    Posts: 158
    Joined: 05-August 08
    Member: 3664

Posted 09 August 2010 - 07:42 PM

Aha that's sorted it - thank you!!!
Posted Image




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users