Jump to content


My LDD won't upgrade


  • Please log in to reply
2 replies to this topic

#1 Torax

Torax

    Posts: 230
    Joined: 09-August 09
    Member: 6953
    Country: Sweden

Posted 22 April 2010 - 05:44 AM

Hey all, I have a problem.
I want to upgrade my LDD to the newer version, with more bricks and all that.
But LLD doesn't.
When I start the program, a message box appears, saying;

Quote

LDD Patch
A newer version of LDD is available for download. Do you want to download and install the new version? Choosing no will run LDD in offline mode.
I have the choice of a red pill and a blue pill, in the forms of a 'Yes' button and a 'No' button. When I click the 'Yes' button, it says 'Downloading Patch' and 'Receiving:' and then the number of bytes received. My internet is incredibly slow, so it takes 1 to 2 seconds to download 0.01 MB.
You'd think it would finish downloading if I'd leave it for long enough, but no.
After a while, ranging from after 3 MB to after 40 MB of the 52.72 MB, it says;

Quote

Patching Failed
LDD cannot access the web browser to retrieve the new version of LDD. Do you want to run in offline mode?
I am positively connected to the internet, but what does the web browser have to do with this? I use the latest version of Mozilla Firefox, but i also have IE installed on my computer. (I am also downloading Google Chrome right now because FF sucks at posting in these forums.)
What am I doing wrong? Should I go to the download page on lego.com and download it from there? IS there a download page at lego.com? Should I blame it all on the horrible internet service?

If it helps, my current version of LDD is 3.0.11, and I run on Windows XP.

Help. :knight:

Edited by Torax, 22 April 2010 - 05:47 AM.

[My Introduction Topic: Link][Trade me your regular LEGO for my BIONICLE! PM me for a list of what BIONICLEs I have!]
[Star Wars Module Standard?]


#2 Mr. Lego-builder

Mr. Lego-builder

  • Work In Progress


    Posts: 853
    Joined: 29-April 05
    Member: 314
    Country: U.S.A.

Posted 22 April 2010 - 09:19 AM

The web browser has nothing to do with LDD updating. Since your connection is so slow, LDD must be giving out timeout errors.

If need be, try to uninstall your current version and download the new version on the official website. It has already been updated to version 3.1.

#3 Torax

Torax

    Posts: 230
    Joined: 09-August 09
    Member: 6953
    Country: Sweden

Posted 22 April 2010 - 10:25 AM

View Postmr. lego_bildur, on Apr 22 2010, 07:19 PM, said:

The web browser has nothing to do with LDD updating. Since your connection is so slow, LDD must be giving out timeout errors.

If need be, try to uninstall your current version and download the new version on the official website. It has already been updated to version 3.1.
Hmm...  Timeout error sounds like a possible explanation. I will get a new internet service provider soon (probably better), so I'll wait until then and then try updating it.
Thanks!

[My Introduction Topic: Link][Trade me your regular LEGO for my BIONICLE! PM me for a list of what BIONICLEs I have!]
[Star Wars Module Standard?]





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users