Jump to content


8039 Problems


  • Please log in to reply
6 replies to this topic

#1 CaptainRex110

CaptainRex110

    Posts: 101
    Joined: 22-May 09
    Member: 6161
    Country: United States

Posted 08 September 2009 - 02:26 AM

Posted Image
Hey, I recently bought the 8039 Venator-class Republic Attack Cruiser, and have been having some problems with it. I was wondering of anyone else was having a problem with the bottom falling off. For me, after a short while of using  the handle, the entire bottom eventually completely separates from the rest of the ship. Any suggestions?
                     - CaptainRex110

Edited by KimT, 28 September 2009 - 07:57 PM.


#2 prateek

prateek

  • Study hard!


    Posts: 10419
    Joined: 09-July 05
    Member: 426
    Country: Canada

Posted 08 September 2009 - 04:14 PM

I think you should just rebuild the set. A lot of problems like that are because the set isn't built right. :wink:

#3 382nd Legionnaire

382nd Legionnaire

    Posts: 311
    Joined: 25-August 09
    Member: 7179
    Country: United States

Posted 08 September 2009 - 06:40 PM

View Postprateek, on Sep 8 2009, 11:14 AM, said:

I think you should just rebuild the set. A lot of problems like that are because the set isn't built right. :wink:

yep, it's too underscale. try modding the critical structure such as the bottom with 4x1, 4x2, studs.

#4 Darth Legolas

Darth Legolas

  • Oh boy vomit brick!


    Posts: 2217
    Joined: 15-December 08
    Member: 4695
    Country: Well umm....

Posted 09 September 2009 - 12:51 AM

Oh no, he didn't build it wrong. The handle I think was a terrible design. I wanted to try pinning it to the bottom with technic supports, but it hasn't worked yet. I'll get back when I have!  :tongue:

Edited by Darth Legolas, 09 September 2009 - 12:51 AM.

...I have a Death Star...

#5 KimT

KimT

  • Retired Backdoor Sneaky Sith


    Posts: 14078
    Joined: 11-November 04
    Member: 101
    Country: Denmark

Posted 09 September 2009 - 07:31 AM

This kind of experince would do good in one of the reviews on this set.
I'll merge this into a review shortly.
When in doubt on how to do things - Check the Tutorial Index
Star Wars Forum Pool on flickr

"Onwards Men! Victory IS at hand" - Famous last words
"How can this possibly go wrong?" -Also Famous last words


Posted Image


#6 allanp

allanp

    Posts: 2734
    Joined: 15-September 06
    Member: 961
    Country: UK

Posted 09 September 2009 - 08:30 AM

I had the same problem with my UCS imperial star destroyer meaning the two bottom panels that are held up by magnets and hinges would separate at the magnets. Built it twice and correctly both times.
Even the best can be made better, but most important is to be excellent to each other and party on dudes!!!!!!

#7 broomhandle

broomhandle

    Posts: 162
    Joined: 21-February 10
    Member: 9661
    Country: United States

Posted 29 December 2014 - 02:14 AM

Hello,

I got this set when in came out, its probably the worst built set. I mad and took it down... i recently built it again thinking what can i mod. It needs so much help.

anybody have pics or ideas?

it basically needs to be rebuilt completely.

what i have done:

took out the 6x6 smooth floor and put in a plate, support for main mount to floor but could be better.

it has up and down flex and side to side flex.

im trying to support the front to back right now...

anybody?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users