Sign in to follow this  
Followers 0
The Explorer

My current WIP, HMS Themis

8 posts in this topic

This is the Main Section There will four of these.

lddscreenshot3.png

This is the bow

lddscreenshot4.png

I hope you like it :cannon::bonaparte:

From my point of view, I think the stern is a little too edgy(hope you get what I mean). You could use some curve pieces on that. Secondly, there are these strange flaps sticking out under the gunports, I think you could rework on those too.

But overall its OK, keep it up!! :pir_laugh2:

Share this post


Link to post
Share on other sites

uhm.. i think the gunports are too near each other.

i've seen good looking gunports at 4 studs even on prefab hulls, so on a brickbuilt hull 2 studs are too near. BTW yours is a pretty nice (and ambitious) project, try to consider some 3x3 studs brickbuilt gunports :)

keep it up!

Share this post


Link to post
Share on other sites

This is going to be huge! I'm very impressed with what I can see so far, however the first picture isn't working for me, I just have a little red x? Anyhoo good luck with the finished design, are you intending to actually build it with bricks or keep it as LDD?

Share this post


Link to post
Share on other sites

Very interesting project, I hope your computer can handling the rendering :pir-classic:

If you're going for accuracy, I'd suggest moving the gunports so that they are staggered. if a ship-of-the-line would use gundecks where all gunports would be placed in straight lines, the recoil of a broadside would rupture the ship's hull and possibly even the rips. I'd also think about a bit more curve in your stern gallery (a lession that I had to teach myself as well when building my first ship)

Share this post


Link to post
Share on other sites

Please resize your pictures to the maximum of 800x600 pixels. :pir-wink:

After that we can discuss the start of this nice vessel!

Share this post


Link to post
Share on other sites

So how is this progressing?

It appears the first image "ddscreenshot3.png" is missing - could you please correct that.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.