Zero (Zblj)

LDD 4.2.5 Bugs

163 posts in this topic

If I place piece 4733 (Brick 1x1 w/ 4 knobs) directly next to part 6541 (Technic Brick 1x1) - which is required to make the backbone of the ship - then try to move the two items together (or any combo thereof) - LDD crashes immediately.

It's a well known problem, as well as being an "illegal" build. Take a look at this thread.

As far as building the Tantive, take a look at what I came up with: LXF File.

Edited by zinfinion

Share this post


Link to post
Share on other sites

The strangest thing!

I am pretty sure it worked before (pre-4.2.5), since I reported it here, when we were discussing duplicates.

But: Flexible Rail Track (64022) does not (no longer?) attach to any other type of Rail Tracks, neither to the logical 53400/53401, but also not to 74746/74747, nor the switch points 75541/75542!

64022_problem.jpg

EDIT: This bug has been solved partially in LDD version 4.3.5: FlexTrack 64022 now does connect with RC Tracks 53400/53401. :thumbup:

Edited by Sjuip

Share this post


Link to post
Share on other sites

The strangest thing!

I am pretty sure it worked before (pre-4.2.5), since I reported it here, when we were discussing duplicates.

But: Flexible Rail Track (64022) does not (no longer?) attach to any other type of Rail Tracks, neither to the logical 53400/53401, but also not to 74746/74747, nor the switch points 75541/75542!

64022_problem.jpg

That it doesn't connect to 74746/74747 or 75541/75542 I guess makes sence, since they are electrified tracks, and 64022 is not.

However, more surprising is that 64022 does not connect to 53400/5340, at least not directly - because I found out it does connect to at least one side of 53401 if you turn 53401 around. In any case, an odd problem. I'm reporting it to TLG.

Last days I'm meeting with slightly misplaced bricks like the 93606 Brick with bow 2x4 or 61678 Brick with bow 1x4. When I connect it with another brick, it do this:

(How it look after putting it, note the 93606 is slightly back so there is a edge and cannot be connected another brick behind it/or you can't connect it ahead of brick (ex. flat tile or any bigger brick unless is corrected))

lddscreenshot1s.th.png

How it should looks like:

(After "correcting" note there is no edge, it's smooth)

lddscreenshot2a.th.png

(Also, please click to the picture for original size, it's better to see it)

Does anyone have the same problem?

Sorry, missed this one before.

A good find indeed. It goes directly to the LDD team without passing GO.

Share this post


Link to post
Share on other sites

Train Undercarriage Problem!

When checking the LXFs for the 2010 Trains sets 7938 (Passenger Train) and 7939 (Cargo Train), I encountered a problem with attaching the undercarriage to the chassis.

Passenger Train 7938 uses the new Chassis 6x24 (92340) and Arches 1x4x2 (6182). However, in LDD the arches do not want to fit in the required position next to the square cutout (indicated by Tan Arch which should be it the position of the blue brick - see picture).

With Cargo Train 7939 something similar happens. It uses Chassis 6x28 (92339) and Arches 1x6x2 (3307). Here, the arches do fit directly over the square cutouts, but LDD does not allow them to fit in the required position next to the cutouts (indicated by the blue brick - see picture)...

92339-92340_problem_.jpg

LXF

Boundary error in both chassis plates??

Of note: this problem does not occur with the 'old' chassis plates (4093 and 6584) nor with the other new 6x24 chassis (92088).

EDIT: These problems/bugs have been solved in LDD version 4.3.5 :thumbup:

Edited by Sjuip

Share this post


Link to post
Share on other sites

Train Undercarriage Problem!

When checking the LXFs for the 2010 Trains sets 7938 (Passenger Train) and 7939 (Cargo Train), I encountered a problem with attaching the undercarriage to the chassis.

Passenger Train 7938 uses the new Chassis 6x24 (92340) and Arches 1x4x2 (6182). However, in LDD the arches do not want to fit in the required position next to the square cutout (indicated by Tan Arch which should be it the position of the blue brick - see picture).

With Cargo Train 7939 something similar happens. It uses Chassis 6x28 (92339) and Arches 1x6x2 (3307). Here, the arches do fit directly over the square cutouts, but LDD does not allow them to fit in the required position next to the cutouts (indicated by the blue brick - see picture)...

92339-92340_problem_.jpg

LXF

Boundary error in both chassis plates??

Of note: this problem does not occur with the 'old' chassis plates (4093 and 6584) nor with the other new 6x24 chassis (92088).

I think in this case it's a matter of missing anti-stud connection points.

Good find in any case. :thumbup:

Share this post


Link to post
Share on other sites

I found a small bug with 2412 Radiator grille that cause crash. Basically, you can place more than 1 brick into same place:

1. place the 2412 into some place but click two times on the same place

2. switch into selection tool and grab it, you'll see there was 2 brick in the same place (brick in brick)

3. remove them and repeat 1. step

4. mark them all (CTRL+A or with mouse) and try move them

5. LDD probably crashed

Also you can do strange things with them like this:

bugedgrille.th.png

top brick is for reference, bottom bricks are... well, there are 5 of them, you can place them like on the picture but after saving and reopening file, LDD will detect it as illegal

(Also, please click to the picture for original size, is better to see it)

Edited by kamos

Share this post


Link to post
Share on other sites

I found a small bug with 2412 Radiator grille that cause crash. Basically, you can place more than 1 brick into same place:

1. place the 2412 into some place but click two times on the same place

Amazing find. I can't remember ever seeing anything like it.

And interestingly it "works" also with a 1x1 tile.

Share this post


Link to post
Share on other sites

Amazing find. I can't remember ever seeing anything like it.

And interestingly it "works" also with a 1x1 tile.

Same goes for 3069 Flat tile 1x2.

Share this post


Link to post
Share on other sites

While building a MOC in LDD, I tried rotating the bit at the end of the 59225 but it rotated a bit too far and turned inside-out.

brickbug..png

I tried rotating it back simply by using the rotate tool, but it got stuck in the side. :sceptic:

brickbug2..png

Share this post


Link to post
Share on other sites

Hi, I'd like to report a bug on this part. Apparently, it can't connect if there is anything underneath it's front "wedge". I tried it with these parts, but no dice. It wouldn't connect. When it doesn't have anything underneath it's front wedge, it connects just fine. If it is already in place, it won't let anything connect to it's underside too...

Edit: added a few screencaps for clarification... To mods: you really should up the limit on attachment. 100KBs? What is this, 1996?

post-7128-133139226698.jpg

Edited by Calabar
Oversized image removed (maximum size allowed is 800x600).

Share this post


Link to post
Share on other sites

Hi, I'd like to report a bug on this part. Apparently, it can't connect if there is anything underneath it's front "wedge".

Edit: added a few screencaps for clarification... To mods: you really should up the limit on attachment. 100KBs? What is this, 1996?

Well spotted bug :thumbup:

About attachments, normally we don't allow any attachments at all. All image and files have to be shared at a separate hosting site, for example Brickshelf. The 100kb is just a service to attach small temporary files.

Share this post


Link to post
Share on other sites

Over time I've found several bugs in LDD but had no way of reporting them (at least not to anyone who could do anything about it!), so I was happy to find this forum.

Here's one that's been sitting in my lap for a while...

LDDScreenShot6-1.png

I've used false colors for some pins to make the issue easier to describe. The blue beam fits quite nicely centered on the green pins or the red pins, but not both the green and red pins. This works in real life, of course. I'm guessing the NXT brick geometry is at fault.

(edited to inline smaller version of image - sorry!)

Edited by iceleftd
Oversized image removed (maximum size allowed is 800x600).

Share this post


Link to post
Share on other sites

Here's another one having to do with the driving ring for a clutch gear.

LDDScreenShot8.png

The red driving ring (#6539) has a channel in the middle of it for a lever to move the ring back and forth. The yellow thin lift arm (#6632) fits in this slot very nicely - in real life only!

At first I thought there was a geometry problem with the driving ring but visually I just can't seem to maneuver the lift arm directly over the slot. It's always just a bit off.

It looks to me like the resolution of the positioning grid doesn't permit the two parts to meet properly. Is this a bug or is there a trick I don't know about?

Share this post


Link to post
Share on other sites

Over time I've found several bugs in LDD but had no way of reporting them (at least not to anyone who could do anything about it!), so I was happy to find this forum.

Here's one that's been sitting in my lap for a while...

I've used false colors for some pins to make the issue easier to describe. The blue beam fits quite nicely centered on the green pins or the red pins, but not both the green and red pins. This works in real life, of course. I'm guessing the NXT brick geometry is at fault.

(edited to inline smaller version of image - sorry!)

Hi and welcome to the forum.

That was an interesting find :thumbup:

And keep those bug reports coming... :classic:

It looks to me like the resolution of the positioning grid doesn't permit the two parts to meet properly. Is this a bug or is there a trick I don't know about?

That's probably so. There was a post about this (how to "cheat" the grid), but I can't really remember when. Maybe someone else remembers (or can explain how to do it)

Share this post


Link to post
Share on other sites

That's probably so. There was a post about this (how to "cheat" the grid), but I can't really remember when. Maybe someone else remembers (or can explain how to do it)

Sometimes all that's needed is the germ of an idea - and you gave it to me. Visually, it looks like the part should be halfway between two adjacent grid positions.

I thought about it for a second and figured out that I could hack the file. The result is this:

LDDScreenShot9.png

The steps I took were:

  1. Export the file with the liftarm in both positions (on both sides of the driving ring groove).
  2. Edit both files and find the entries for the liftarm.
  3. Calculate the averages of the tx, ty and tz values.
  4. Replace the tx, ty and tz values in one of the files with the averaged values.
  5. Save this file and re-import.
  6. The liftarm is now centered on the driving ring's groove and can be rotated into place as shown.

This positioning can be saved just fine and the two objects can be moved as long as they are moved together. If the liftarm is moved separately, it snaps back to the grid and you have to go back to step 1.

Obviously this is still a bug that should be fixed someday, I'm just not sure of the best way.

Edited by iceleftd

Share this post


Link to post
Share on other sites

@ iceleftd: Very clever! :classic: It should be noted, however, that the normal part for the Technic Driving Ring is the 6641 "Technic Changeover Catch" (which has a Technic Axle hole on the flat, square portion facing away from the camera). That part exists in LDDextended mode:

6641.gif

Share this post


Link to post
Share on other sites

Sometimes all that's needed is the germ of an idea - and you gave it to me. Visually, it looks like the part should be halfway between two adjacent grid positions.

I thought about it for a second and figured out that I could hack the file. The result is this:

The steps I took were:

  1. Export the file with the liftarm in both positions (on both sides of the driving ring groove).
  2. Edit both files and find the entries for the liftarm.
  3. Calculate the averages of the tx, ty and tz values.
  4. Replace the tx, ty and tz values in one of the files with the averaged values.
  5. Save this file and re-import.
  6. The liftarm is now centered on the driving ring's groove and can be rotated into place as shown.

This positioning can be saved just fine and the two objects can be moved as long as they are moved together. If the liftarm is moved separately, it snaps back to the grid and you have to go back to step 1.

Obviously this is still a bug that should be fixed someday, I'm just not sure of the best way.

Yepp, that was one of the methods (hard core editing :tongue:)

But I seem to remember there was a clever way to do it in the GUI too.

Share this post


Link to post
Share on other sites

But I seem to remember there was a clever way to do it in the GUI too.

Angled freemovers. For example, move .5 LDU in +X Plane and 1.5 LDU in +Y Plane (since 2 LDU is smallest move) then do .5 X and 1.5 -Y for a sum total of 1 X, 0 Y. Two angled freemovers set to 22.5 degrees and positioned properly would achieve this. The math is rather simple to figure from there.

I used 3.0625 degrees on the front panels of the Galactic Enforcer to move them down .125 LDU (0.05mm) to avoid a collision.

Share this post


Link to post
Share on other sites

@ iceleftd: Very clever! :classic: It should be noted, however, that the normal part for the Technic Driving Ring is the 6641 "Technic Changeover Catch" (which has a Technic Axle hole on the flat, square portion facing away from the camera). That part exists in LDDextended mode:

6641.gif

Thanks for pointing this part out. The use of a thin liftarm as a substitute permits the shifting axle to be parallel to the driving ring axle and only 2 LU apart. I can't think of a way to do that using 6641 and the same axle orientation without moving the axles 5 LU apart.

Share this post


Link to post
Share on other sites

@ iceleftd: From Blakbird's Technicopedia, here's how the Lego Technic Driving Ring works: "The driving ring, in combination with a pair of idler gears which do not turn with their axle of support, allow functions to be engaged or disengaged. It slides over the ridged axle joiner which we first saw in 1993. Small tabs on the driving ring allow it to lock along these ridges, but still slide with some extra force. The driving ring grips the longitudinal grooves on the axle joiner causing them to rotate together. A circumferential groove in the middle of the ring allows it to be pushed along the axle joiner in either direction. A set of 4 driving dogs on either end then mate with a 16 tooth idler gear allowing the idler's rotation to be either synched with the axle or allowed to spin freely.

"The animation shows how the new driving rings work to engage and disengage the clutch/idler gears. The driving ring is shown in red. The lower axles are joined with the gray axle joiner. The driving ring rotates with the axles. At first, the driving ring is disengaged so both the dark gray and green gears are not driven and slip on the axle. The driving ring then engages the green gear and thus drives the blue gear. Because the driving ring does not use gear teeth but rather uses four tapered driving dogs, there is considerable backlash between the driving ring and the gear. The allows the driving ring to be engaged even while it and the mating idler gear are turning at different speeds.

driving.gif

"A fairly small number of sets have contained these parts over the years. It is generally used either in a transmission used for gear changes or in a gearbox used to select between multiple motorized functions. The driving ring originally always light gray but has more recently been typically red."

Edited by DLuders

Share this post


Link to post
Share on other sites

Hi there! I think I got a new one: the old 24 teeth crown gear is badly modeled, like someone rushed it. It has no resemblance with the actual piece (straight edges instead of round, shallow teeth) and to make things worse, atleast on one of the side, it can't touch with another part. Together I attach a picture so you can see the differences.

post-7128-133245448742.jpg

Share this post


Link to post
Share on other sites

Hi there! I think I got a new one: the old 24 teeth crown gear is badly modeled, like someone rushed it. It has no resemblance with the actual piece (straight edges instead of round, shallow teeth) and to make things worse, atleast on one of the side, it can't touch with another part. Together I attach a picture so you can see the differences.

I see what you mean. Good find. :thumbup:

Share this post


Link to post
Share on other sites

Making assembly instruction within LDD still stinks bad. I wanted to see how the new LEGO retail store set (LXF posted elsewhere in LDD forum) and there's quite a lot of floating bricks and direction that don't make sense. For example, below:

LDDScreenShot1.png

Have you putting the ceiling light up before putting the roof panel down. Exected: put the light assembly on the roof first, then place the roof on the rest of the set. Later on in the instruction, LDD has the rest of the store's interior and tiled floor, with the 2 large base plates added in last. The base plates should have been very first step, not last.

tl:dr LDD's building instruction stinks with weird steps, floating bricks, and other unusual method that would have been hard to do IRL

Share this post


Link to post
Share on other sites

Making assembly instruction within LDD still stinks bad. I wanted to see how the new LEGO retail store set (LXF posted elsewhere in LDD forum) and there's quite a lot of floating bricks and direction that don't make sense. For example, below:

If you download the zinfinion version it actually produces better instructions (for some reason I haven't looked into).

Also, to get LDD to generate good instructions you need to prepare the model a bit. For example remove snot modules and place those to the side.

Share this post


Link to post
Share on other sites

If you download the zinfinion version it actually produces better instructions (for some reason I haven't looked into).

Likely due to creating an overall group, with the roof and the store as sub groups.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.