Superkalle

[KEY TOPIC] LDD 4 Bugs and brick errors

848 posts in this topic

NEW BUG:

M motor's axle cannot be rotated, which causes older models with rotated axle to remove the motor...

Share this post


Link to post
Share on other sites

After some resarch I found the M motor is totally corrupted... Anywere you place it gets deleted... Evne if it the only brick in the file.

Share this post


Link to post
Share on other sites

Give us some details. Like a part number (which is now so easy to search&find in LDD :classic:)

BUG: Color 297 (Warm gold), which is the gold color in for example Atlantis sets, is missing in the color palette. All other colors (except Maersk Blue) seems to be there.

Share this post


Link to post
Share on other sites

A few things so far. Firstly, if you enable any of visual features, models you could open before will not open if they are really big (LDD crashes).

Also, 4.0 is much more sensitive about the illegal placement of pieces, as models I had built in 3 worked perfectly, and in 4.0 I had 56 pieces removed.

Also for large models, trying to "check whether model can be purchased" crashed LDD (but its still a really cool feature).

Oh, and is this the right place to mention bug fixes that were in 3? Because one of the most annoying is fixed:

The height difference for baseplates is fixed, so the 8x16 is no longer slightly thicker!!

Share this post


Link to post
Share on other sites

Give us some details. Like a part number (which is now so easy to search&find in LDD :classic:)

BUG: Color 297 (Warm gold), which is the gold color in for example Atlantis sets, is missing in the color palette. All other colors (except Maersk Blue) seems to be there.

Simply Power functions M motor has a catastrophic bug. Anywhere you place it, it gets removed when you reopen model. No excpetions!

Share this post


Link to post
Share on other sites

Simply Power functions M motor has a catastrophic bug. Anywhere you place it, it gets removed when you reopen model. No excpetions!

Aha, you mean 58120. Yepp that was a particularly nasty one. Ouch.

Share this post


Link to post
Share on other sites

Oh, and is this the right place to mention bug fixes that were in 3? Because one of the most annoying is fixed:

The height difference for baseplates is fixed, so the 8x16 is no longer slightly thicker!!

Good idea! Can you start a new topic about "fixed bugs in LDD 4"

First LDD 4.0 bug! These two should fit together:

fit.png

Which parts are those?

Share this post


Link to post
Share on other sites

Technic steering-gear 3M and T.steering gear, bearing 2M

Aha you mean 32069 and 32068 (gotta love that new status bar info) :classic:

Can you give an example set (instruction) where this connection technique is used.

Share this post


Link to post
Share on other sites

When decorating a minifig head, a lot of the prints don't fit on the screen.

Share this post


Link to post
Share on other sites

When decorating a minifig head, a lot of the prints don't fit on the screen.

A lot? Interesting... I encountered a single print for which that occurred in 3.0. Are you saying there's new prints in LDD 4.0?

Looks like I'm going to have to do some hacking...

Share this post


Link to post
Share on other sites

A lot? Interesting... I encountered a single print for which that occurred in 3.0. Are you saying there's new prints in LDD 4.0?

Looks like I'm going to have to do some hacking...

No. The bottom two rows don't fit on the screen. It's just the old prints, but there are a lot anyways.

Edited by prateek

Share this post


Link to post
Share on other sites

When decorating a minifig head, a lot of the prints don't fit on the screen.

I'm not sure I follow. Can you post a screenshot please.

EDIT: What screen resolution do you have?

Share this post


Link to post
Share on other sites

I'm not sure I follow. Can you post a screenshot please.

EDIT: What screen resolution do you have?

asdlkfhasdfkljsda.jpg

1024x768 is my resolution :classic:

Share this post


Link to post
Share on other sites

When decorating a minifig head, a lot of the prints don't fit on the screen.

I found that too. I'm on the same screen resolution.

The 'Plate 1x1 w. up right holder' doesn't clip onto the wheel pin of the 'Three-wheeled motor cycle' as seen in the modern SW speeder bikes.

Share this post


Link to post
Share on other sites

I found that too. I'm on the same screen resolution.

The 'Plate 1x1 w. up right holder' doesn't clip onto the wheel pin of the 'Three-wheeled motor cycle' as seen in the modern SW speeder bikes.

Two bugs in one smash (as we say in Sweden. I think you english speaking say two birds with one stone, right?)

curved and straight road plates do not let their painted parts line up

Well spotted, but that actually an old bug that hasn't been fixed yet.

Share this post


Link to post
Share on other sites

Two bugs in one smash (as we say in Sweden. I think you english speaking say two birds with one stone, right?)

Yes, that's right. :tongue:

It's strange as the clip attaches to a 'Bearing element 2x2, double' which is basically the same pin but attached to a 2x2 plate. :sceptic:

It's also very odd that they forgot Pearl/Warm Gold. It's a very common colour at the moment.

EDIT: I found two more:

The 'lamp shade' part does not have a hole right through, so bars cannot be pushed through.

Also, some technic pin parts do not allow bars to be pushed in such as 'Module bush' and 'Stub w friction bush 3 m'

Edited by ADHO15

Share this post


Link to post
Share on other sites

Part 89670 (the right arm of large Rock Monsters from Power Miners) does not attach to any Technic-pin-click-hinge. That is, parts with the same style of joints as Exo-Force and Knights' Kingdom II. Examples include 87959 (the large Lava Monster body), 85049 (the large Rock Monster body), and 48172 (2x2 with double click hinge). As a point of comparison, part 89669 (the left arm of large Rock Monsters) will attach to any of these parts just fine.

The horse (part 75998) also retains a bug from the last versions. There's a certain range of angles which the neck cannot be hinged to.

Share this post


Link to post
Share on other sites

The 'lamp shade' part does not have a hole right through, so bars cannot be pushed through.

Can someone confirm that the 6942 Lamp Shade has a hole also in the old SCALA sets from the late 90's. Otherwise we might be looking at two DesignID's - one with, and one without the hole.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now

  • Recently Browsing   0 members

    No registered users viewing this page.