Zblj

[KEY TOPIC] LDD 3 bugs and brick errors

273 posts in this topic

Good findings! And excellent that you made a video. What tool did you use to capture screen video?

I built the 7998 Heavy Hauler main unit in LDD using LU mode, and have found a problem with rotation tool whereby it will not properly rotate parts which are attached to parts which extend/retract. Please see the attached .lxf file (in zip archive) for more details.

NOTE: This only contains the first truck, neither the driver of the truck nor the second dump truck trailer unit are included.

I would like to request a feature enhancement for placing parts, especially large parts like the dump truck container itself: Please allow LDD some method of pointing to an attachment point on one part, and an attachment point on the main model, and allow this method to be used by LDD to figure out what angle the part has to be at in order for that part to seat properly onto the model. It does do this for some parts automatically, but only if they have studs on them, studless it seems do not get this treatment.

Cheers ...

ghyde

greendumptruck LU.zip

Share this post


Link to post
Share on other sites

I built the 7998 Heavy Hauler main unit in LDD using LU mode, and have found a problem with rotation tool whereby it will not properly rotate parts which are attached to parts which extend/retract. Please see the attached .lxf file (in zip archive) for more details.

NOTE: This only contains the first truck, neither the driver of the truck nor the second dump truck trailer unit are included.

I would like to request a feature enhancement for placing parts, especially large parts like the dump truck container itself: Please allow LDD some method of pointing to an attachment point on one part, and an attachment point on the main model, and allow this method to be used by LDD to figure out what angle the part has to be at in order for that part to seat properly onto the model. It does do this for some parts automatically, but only if they have studs on them, studless it seems do not get this treatment.

Cheers ...

ghyde

greendumptruck LU.zip

Yeah in this case you can only remove cylinder rotate dump bed and reattach cylinder again. Hinge align tool might be heplfull here.

Share this post


Link to post
Share on other sites

Any reason I'm not allowed to put a lid on a 2x2 barrel? It's used in a lot of manual but no matter how I tried, the round 2x2 plate never fits on top of the barrel. Every time I try to move the 2x2 round plate onto the barrel, LDD tries to place it under the barrel. I tried flipping both barrel and plate and tried sitting the barrel on top of the plate, LDD tries t place the barrel below the plate!!!

If it was an illegal design, then some 100's of instruction broke that rule :tongue:

It is a legal design, and from what I understand it will be fixed in next LDD version. Let's hope for it.

Share this post


Link to post
Share on other sites

I've encountered another bug! Everytime when I try to send a model to the Creator Gallery in LU Mode & click on Accept, nothing happens!

Are we in a world full of paranormal activity?!

Edited by BrickWild

Share this post


Link to post
Share on other sites

I've encountered another bug! Everytime when I try to send a model to the Creator Gallery in LU Mode & click on Accept, nothing happens!

Are we in a world full of paranormal activity?!

I'm not sure I understand. You are not supposed to be able to upload LU Mode models to the DesignByMe Gallery (which I supposed you refer to, even if you call it Creatory Gallery). LU Mode is for AFOLs only. If you read carefully here, it says to clearly.

Share this post


Link to post
Share on other sites

This part doesnt rotate smoothly pinside in axle hole:

33299.png

Share this post


Link to post
Share on other sites

This part doesnt rotate smoothly pinside in axle hole:

33299.png

I also note a 3.2 mm bar will not fit into the technic pin hole. Is it supposed to do that with a physcial brick?

Share this post


Link to post
Share on other sites

I think bar should go through. Talk bout bars, they should also fit all the way through normal pins, not just half way.

Share this post


Link to post
Share on other sites

I think bar should go through. Talk bout bars, they should also fit all the way through normal pins, not just half way.

You mean ones with or without friction? I just recently was messing around with the extra pieces from my Space Police Central set, and was surprised to find that there's a sort of a "stopper" in the center of frictionless 2-length pins. In friction pins a bar can go all the way through. No idea why this is the case.

Share this post


Link to post
Share on other sites

I think bar should go through. Talk bout bars, they should also fit all the way through normal pins, not just half way.

Regarding pins and putting a 3.2 bar through, this is what I have found out (and these rules will apply in LDD in the future):

Allowed/Legal to go through all the way

2780 (4459 at BrickLink) (black)

4274 (blue or light bley)

32002 (dark bley)

4459.png4274.png32002.png

Allowed to go though half through (i.e. only allowed to go 1 module in)

32556 (tan or light bley) (aka x202 in BrickLink)

3673 (light bley)

32556.png3673.png

Not allowed in at all (due to a stop at the end)

6558 (normally blue or black)

32054 (can be multiple colors)

6558.png32054.png

NOTE 1

Most parts with a technic pin will not allow a bar to be inserted, however a few will strangely enough. The only I've found are these:

30526

30592

30526.png30592.png

If you can find any others that will effortlessly allow a bar, post it here in the forum!

NOTE2

Transparent bars are normally not allowed even half-way in since they are made of polycarbonate, which has much higher friction against ABS. This means they are harder for kids to take aparts > illegal. This will not matter to us LDD users however, since LDD does not distinguish between materials (read: colors).

Share this post


Link to post
Share on other sites

Yeah friction pin should allow all the way through, but it doesnt. Dunno why same doesnt reply for frictionless 2L pin?

Share this post


Link to post
Share on other sites

Hi all,

Been playing around with LDD for a while, but only found this forum yesterday.

There's a bug that was annoying me when building 6389 - I've read through this thread and can't see a mention of it. The "inverted windscreen 3x4x4" will not accept a brick placed inside it at its base.

invwindscreenbug.jpg

The computer should fit inside it, but doesn't. On the right of the pic, it's floating one plate's thickness up in the air, so it's only the base of that windscreen that doesn't like it.

Share this post


Link to post
Share on other sites

Hi all,

Been playing around with LDD for a while, but only found this forum yesterday.

The computer should fit inside it, but doesn't. On the right of the pic, it's floating one plate's thickness up in the air, so it's only the base of that windscreen that doesn't like it.

Hi there

Welcome to the LDD forum. Hope you'll enjoy it here. :classic:

And yepp, that seems like a classic brick-bug. I'll report it to TLG!

Share this post


Link to post
Share on other sites

These wheels can go to deep, edge has no collision.

wheelcol.png

Share this post


Link to post
Share on other sites

Is this part included in LDD? It used to be but I can't find it.

2871.png

Share this post


Link to post
Share on other sites

Is this part included in LDD? It used to be but I can't find it.

2871.png

Nope. Just checked LDD manager, and it's not in there.

Share this post


Link to post
Share on other sites

Nope. Just checked LDD manager, and it's not in there.

Thanks! I'd like that part in LDD 4.0!

Share this post


Link to post
Share on other sites

I ran across this error while building the 8001 Technic Battle Droid.

lddscreenshot6.png

The red piece refuses to rotate in between those two angles, and won't connect in that zone either.

Edited by Daedalus304

Share this post


Link to post
Share on other sites

I ran across this error while building the 8001 Technic Battle Droid.

lddscreenshot6.png

The red piece refuses to rotate in between those two angles, and won't connect in that zone either.

yep already reported the bug, teh red piece wont spin smoothly.

You can attach that part there using an axle. First put it on the axle which goes to the angled part of the bent beam and than simply pusht it all the way in.

Edited by Zblj

Share this post


Link to post
Share on other sites

Well, it's more than just a rotation thing. I can't get it to connect right at all here. As a more precise explanation, I need it to be where the red bars are, but it doesn't connect. I tried attaching it to the black cross axle hoping it would snap into place on the blue part, but it's insistent.

ldd_problem.png

Sorry if this is what you were talking about. >.< It seemed what you suggested was to get the part along the bent beam, when I need to to keep going straight.

Share this post


Link to post
Share on other sites

Yeah, I cant get it in like that too... So just build the robot with bent knees :tongue:

Share this post


Link to post
Share on other sites

Yeah, I cant get it in like that too... So just build the robot with bent knees :tongue:

Haha, looks like I'll have to! He's sure going to have some strange posture. :grin:

Share this post


Link to post
Share on other sites

Here's the problems I ran into trying to build 10175 (As posted in this topic/post).

LDDScreenShot16.png

In the set, you have to clip those together to hold the covers for the wing struts in place, but in LDD they won't snap. What's interesting is that if you turn the blue piece upside-down (With the setup in the picture), the bar on the end can rest naturally inside the clips. It still won't connect, but it obviously can/does fit.

These two are more understandable, but I'll post them anyways to help explain what's not right in the 10175 file.

LDDScreenShot17.png

In the set, you're supposed to have the red brick all the way in (like the blue one is), but it won't do so. They seemed to fit together just fine putting the physical set together, but there's probably a minor offset that's bugging LDD.

LDDScreenShot18.png

I'm pretty sure this sort of thing has been gone over, they don't like studs in Technic holes. I'm not really sure it counts as a bug.

Now here's one I know is a glitch for sure, found building 7180.

LDDScreenShot15.png

The red part will not rotate past this point. Funny thing is, the other end of the blue brick does NOT have the same problem, I could get full motion over there.

EDIT: Whoops, forgot another 10175 one.

LDDScreenShot14.png

The red part connects just fine, and will stay, but when you load the file it will say it was placed incorrectly and remove it. The bley assemply it's in had to be "tricked" there because of the technic stud height difference, but it's weird that the jumper plate is the only one of them removed for being placed "wrong", and the slopes/cone get to stay.

Edited by Daedalus304

Share this post


Link to post
Share on other sites

I have a question. Why does LDD remove improperly placed bricks anyways? Does the program crash if they are kept?

Edited by prateek

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Recently Browsing   0 members

    No registered users viewing this page.