Sign in to follow this  
Followers 0
kapten jei

Rebel Medium Infiltration Tank

6 posts in this topic

indexed.gif

The Rebel Medium Infiltration Tank, or RMIT, was heavily used by the rebellion during it's early days of rebelling.(hehehehe) It is a very fast and nimble unit, but packs a heavy punch. It has only one pilot, and the turret is partially controlled by the droid for maximum firing accuracy even in the heat of battle. This unit is usually deployed in hordes because it is easy to manufacture and only required one personnel to pilot it. The turret fires a heavy blast of laser energy, comparable to the guns on the Republic Gunship. It can target both air and land units. It can take on almost anything one on one. The rumble of the RMIT's engine strikes fear on even the most experienced Imperial trooper.

2attack.jpg

Used 250 pieces

Includes 8 figs

2figs2.jpg

1 Rebel Commander

1 Rebel Pilot (the one in orange)

6 Rebel Troopers

front

2front.jpg

right

2right.jpg

left

2left.jpg

top

2top2.jpg

back

2back.jpg

turret

2turret.jpg

targeting droid

2droid.jpg

on the move

2attack2.jpg

The design was inspired by the snow speeder. I basically just made it fatter, and added a turret of doom. XD Most of the parts I used are from the Imperial Dropship and the Rebel Scout Speeder.

Gallery

Comments and critiques please!

Edited by kapten jei

Share this post


Link to post
Share on other sites

Thats a great model! I love the cockpit and the turret of doom. :wub::tongue:

Greetings,

JD

Share this post


Link to post
Share on other sites
Thats a great model! I love the cockpit and the turret of doom. :wub::tongue:

Greetings,

JD

Thanks! You can easily make that cockpit with Rebel and Stormie battle packs.

Share this post


Link to post
Share on other sites

Same as your other entry.

Great, but some of the pics are 'dead' and their links need fixing.

(This is the 3rd browser I've tried to view them in)

Share this post


Link to post
Share on other sites
Same as your other entry.

Great, but some of the pics are 'dead' and their links need fixing.

(This is the 3rd browser I've tried to view them in)

Thanks. Sorry for giving you a lot of work. I think I fixed it. I reuploaded the pics on photobucket. Seems like Picasa isn't very friendly with deeplinks.

Share this post


Link to post
Share on other sites
Thanks. Sorry for giving you a lot of work. I think I fixed it. I reuploaded the pics on photobucket. Seems like Picasa isn't very friendly with deeplinks.

No problem and pics are perfect now :classic:

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0

  • Recently Browsing   0 members

    No registered users viewing this page.